The access key of the context menu should be unified

VERIFIED FIXED in Firefox 64

Status

()

P3
normal
VERIFIED FIXED
4 months ago
2 months ago

People

(Reporter: kazz, Assigned: jaws)

Tracking

(Blocks: 1 bug)

64 Branch
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified, firefox65 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Some access keys shown in context menu are different depending on context.
It's very confusing...

Access key for bookmark:
Single tab:
Bookmark [T]ab

But if multi tabs are selected:
Boo[k]mark Tabs

-> should be both [B]ookmark?

Accesskey for mute/unmute:
[M]ute Tab / Un[m]ute Tab

Thou access key for pin/unpin:
[P]in Tab / Unpin Ta[b]

-> should be Un[p]in?
Blocks: 1458007
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Created attachment 9015995 [details]
Bug 1497505 - Update the accesskeys of the bookmark tab(s) and (un)pin tab(s) to make them consistent regardless of the state. r?flod

I have not changed the entity names since the meaning of the strings has not changed.

Comment 2

4 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6bfe39bf5e4d
Update the accesskeys of the bookmark tab(s) and (un)pin tab(s) to make them consistent regardless of the state. r=flod

Comment 3

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6bfe39bf5e4d
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
status-firefox64: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
The bookmark and pin changes are ok on both nightly 65.0a1 (2018-11-11) and 64.0b8.
Verified over macOS10.14, Win10, Ubuntu16.04.

Bookmark - B
Pin/Unpin - P


While verifying the changes; the mute/unmute case mentioned by the reported seems to be overlooked.
Is that intended?

The issue would still be: Unmute ta[b]s  / M[u]te tabs.
There would still be a scenario where the B key would toggle between the unmute and bookmark option if the tab is already muted.
Flags: needinfo?(jaws)
Thanks for catching that. Can you please file a bug to fix the the "Unmute tabs" and "Mute tabs" accesskey?
Flags: needinfo?(jaws)
Depends on: 1506878
Blocks: 1506878
No longer depends on: 1506878
Hello all,

Confirming as verified fixed on the latest Nightly Nightly 65.0a1(2018-11-22)and the latest Beta 64.0b12.

Verified on Win10x 64, Ubuntu 16.04 and macOS 10.12.6.
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
status-firefox65: --- → verified
You need to log in before you can comment on or make changes to this bug.