Need to support ldap server preferences pre-configuration/locking

VERIFIED FIXED

Status

MailNews Core
LDAP Integration
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Srilatha Moturi, Assigned: Srilatha Moturi)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2 RTM],custrtm+)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

16 years ago
This bug is for pref-configuring and locking the ldap server preferences.
*  General requirements
   o pre-configurate and lock server preferences before deploying them.
   o the ability to designate which server is the default for ldap addressing.
   o when a preference is locked, the associated UI in the client should be 
     disabled/greyed out.
   o end users should not be able to modify/delete pre-configure settings
   o the solution should work with both new profiles and existing profiles 
     which might have server settings already.
   o there should be pref to indicate whether users are allowed to add new ldap
     directory.
   o handling pre-existing server settings in old profiles:
     leave them alone (end users still can use them) but use the designated(new) 
     server setting as the default. When locked, users won't be allowed to 
     switch the default server.
This bug is being created off of bugscape bug 15605, since the fix is in the 
mozilla tree and will new drivers approval
(Assignee)

Comment 1

16 years ago
changing component and QA.
Also copying over the keywords from bugscape bug.
Component: Simple MAPI → LDAP Mail/News Integration
Keywords: nsbeta1+
QA Contact: trix → blee
Whiteboard: [ADT2 RTM],custrtm+
(Assignee)

Comment 2

16 years ago
Created attachment 86714 [details] [diff] [review]
proposed patch
(Assignee)

Comment 3

16 years ago
The above patch has an sr=sspitzer. copying his comments over from bugscape bug 
15605

------- Additional Comment #21 From Seth Spitzer 2002-06-06 15:21 -------

(From update of attachment 6763 [details])
sr=sspitzer

srilatha tells me that in all places where we set the disabled attribute (but
do not remove it), are places where we rebuild the UI from scratch when looking
at it  for another ldap server.

she also says that the whitespace / tab issues are because the diff is -uw.
Status: NEW → ASSIGNED

Comment 4

16 years ago
*** Bug 149757 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
From the update of attachment (id=86714) :

+          if ((selectedDir.indexOf(ldapUrlPrefix, 0)) == 0)
+          {
+            var prefName = selectedDir.substr(ldapUrlPrefix.length, 
selectedDir.length);
+			var disable = false;
+	        try {
+	          disable = gPrefs.getBoolPref(gCurrentDirectoryServerId 
+ ".disable_delete");
+	        }
+	        catch(ex){
+	          // if this preference is not set its ok.
+	        }
+            if (disable)
+              return false;
+          }


I donot see why you have var prefName defined, do you need the ldapURLPrefix 
substring out of the selected dir string ?
(Assignee)

Comment 6

16 years ago
Created attachment 87605 [details] [diff] [review]
updated patch

>I donot see why you have var prefName defined, do you need the ldapURLPrefix 
>substring out of the selected dir string ?
yes, since prefName is the prefix ldap_2.server.<server-name> and the first
parameter in the following line should be prefName. this was a mistake made by
me while changing the prefnames. Thanks for catching this.
+		  disable = gPrefs.getBoolPref(gCurrentDirectoryServerId 
+ ".disable_delete");

This patch has the change mentioned above.

Comment 7

16 years ago
r=rdayal.
(Assignee)

Comment 8

16 years ago
Comment on attachment 87605 [details] [diff] [review]
updated patch

r=rdayal from his comments. and carrying over the sr=sspitzer from the previous
patch
Attachment #87605 - Flags: superreview+
Attachment #87605 - Flags: review+

Comment 9

16 years ago
Let's land this on the trunk.  blee, can you either try out Srilatha's most
recent test build or the trunk after this lands?
Keywords: adt1.0.1, mozilla1.0.1
(Assignee)

Comment 10

16 years ago
Fix checked into the trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
Checked this out on srilatha's 6/11 test bld and found no new problem, 
but setting the parameter value to "false" in 
lockPref("ldap_2.disable_button_add", true) and 
lockPref("ldap_2.servers._ncadm_preconfigured.disable_button_download", true)
didn't do anything. Changing "lockPref" to "Pref" unlocked the pref's. Is this
the correct/expected behavior?
(Assignee)

Comment 12

16 years ago
Yes, that is the expected behaviour. The buttons are disabled only if they are 
lcoked and the value doesnot matter. I just spoke to rvelasco and he agrees with 
me on this.
(Assignee)

Comment 13

16 years ago
Created attachment 87734 [details]
configuration file

This is the file I used to preconfigure and set a default ldap server. Note
that the id3 in mail.identity.id3.directoryServer and
mail.identity.id3.overrideGlobal_Pref has to replaced with the right idenity
key. Also note that
ldap_2.servers._NCADM_preconfig.disable_delete has to be set to true if you
want  to disbale the delete button for the preconfigured server.
Attachment #86714 - Attachment is obsolete: true

Updated

16 years ago
Blocks: 144547

Updated

16 years ago
Blocks: 141352
No longer blocks: 144547

Comment 14

16 years ago
Marking adt1.0.1+ on behalf of the adt for checkin to the 1.0 branch.  Please
get drivers approval before checking in.
Keywords: adt1.0.1 → adt1.0.1+

Comment 15

16 years ago
Verified on Windows 2002-06-17-12-trunk bld.
Will mark the bug VERIFIED after testing on Mac and Linux trunk blds tomorrow.

Updated

16 years ago
Attachment #87605 - Flags: approval+

Comment 16

16 years ago
Comment on attachment 87605 [details] [diff] [review]
updated patch

a=asa (on behalf of drivers) for checkin to the branch.

Updated

16 years ago
Keywords: mozilla1.0.1 → mozilla1.0.1+

Comment 17

16 years ago
Also verified on Linux 2002-06-17-21-trunk, and MacOS X 2002-06-17-08-trunk blds.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 18

16 years ago
Fix checked into the branch
Keywords: adt1.0.1+, mozilla1.0.1+ → fixed1.0.1

Comment 19

16 years ago
1.0 brach bits also verified - see bugscape #15605.
Keywords: fixed1.0.1 → verified1.0.1
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.