Closed Bug 1497656 Opened Last year Closed Last year

[de-xbl] Message opened in stand-alone window (open in new window) is missing the Subject

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jorgk, Assigned: mkmelin)

References

(Regressed 1 open bug)

Details

(Keywords: regression)

Attachments

(3 files)

Looks like a regression from some de-XBL activity.
For me Subject and also Date is missing in the standalone window. In a tab and message preview pane in 3-pane window all fields look OK.
The reason behind missing subject field is that the custom element is not registered when headerValue of mail-headerfield is changed. https://searchfox.org/comm-central/source/mail/base/content/msgHdrView.js#1007

Magnus, I will need your help here for making sure that mail-headerfield custom element is into scope when new window is opened. We probably have to find a foolproof way of letting the custom element definition in scope before any window loads.

I am attaching screenshot to confirm what I am saying.
Flags: needinfo?(mkmelin+mozilla)
Attached image screenshot1.png
Attached image Screenshot2.png
customElements.get(node.nodeName) or node instanceof MozXULElement, makes sure that node is custom elment node and not a normal xul node.
Blocks: 1491698
Needed to load the customElements.js earlier.
Assignee: arshdkhn1 → mkmelin+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)
Attachment #9016559 - Flags: review?(acelists)
Comment on attachment 9016559 [details] [diff] [review]
bug1497656_standalone_win_custom_elements.patch

Review of attachment 9016559 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me.
Attachment #9016559 - Flags: review?(acelists) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/e2b203306dad
set up Thunderbird custom elements on DOMWindowCreated, to make them work also in the stand-alone message window. r=aceman
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Regressions: 1580420
You need to log in before you can comment on or make changes to this bug.