Closed Bug 1497739 Opened Last year Closed Last year

"TypeError: event.target.nodePrincipal is undefined; can't access its "isNullPrincipal" property" in BrowserCLH.js

Categories

(Toolkit :: Password Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: gbrown, Assigned: MattN)

References

Details

(Keywords: regression)

Attachments

(1 file)

Currently the logcat for most Android 4.3 tests contains something like this:

https://treeherder.mozilla.org/logviewer.html#?job_id=204349090&repo=mozilla-central

https://taskcluster-artifacts.net/Iq33ik8SRv2ZZaXbWfBoFw/0/public/test_info//logcat-emulator-5554.log

10-09 15:37:20.291   826   850 E GeckoConsole: [JavaScript Error: "TypeError: event.target.nodePrincipal is undefined; can't access its "isNullPrincipal" property" {file: "jar:jar:file:///data/app/org.mozilla.fennec_aurora-1.apk!/assets/omni.ja!/components/BrowserCLH.js" line: 189}]
:mattn - This may have been introduced by bug 1426767. Can you have a look?
Flags: needinfo?(MattN+bmo)
The problem is a "blur" event with a `window` as event.target.
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Component: Testing → Password Manager
Flags: needinfo?(MattN+bmo)
Priority: -- → P1
Product: Firefox for Android → Toolkit
shouldIgnoreLoginManagerEvent (BrowserCLH.js#189)
_initLoginManagerEvents (BrowserCLH.js#221)
setActive (browser.js#3949)
selectedTab (browser.js#1101)
addTab (browser.js#1237)
onEvent (browser.js#1971)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/d667abe7240c
Check blur event target is HTMLInputElement before shouldIgnoreLoginManagerEvent. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/d667abe7240c
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Comment on attachment 9017385 [details]
Bug 1497739 - Check blur event target is HTMLInputElement before shouldIgnoreLoginManagerEvent. r?Gijs

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1426767

User impact if declined: Not sure, Android-only. Potentially breaks something related to tab switches or focus changes?

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Trivial fix to check the event's target type before assuming it's a node.

String changes made/needed: None
Attachment #9017385 - Flags: approval-mozilla-beta?
Comment on attachment 9017385 [details]
Bug 1497739 - Check blur event target is HTMLInputElement before shouldIgnoreLoginManagerEvent. r?Gijs

63 is on release now.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: 

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): 

String changes made/needed:
Attachment #9017385 - Flags: approval-mozilla-beta? → approval-mozilla-release?
Comment on attachment 9017385 [details]
Bug 1497739 - Check blur event target is HTMLInputElement before shouldIgnoreLoginManagerEvent. r?Gijs

User impact of the bug is not clear and it just landed, so this doesn't seem like a good candidate for an RC.
Attachment #9017385 - Flags: approval-mozilla-release? → approval-mozilla-release-
Duplicate of this bug: 1501237
You need to log in before you can comment on or make changes to this bug.