Closed Bug 1497791 Opened 1 year ago Closed 1 year ago

[BinAST] "use strict" seems to have no effect

Categories

(Core :: JavaScript Engine, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- disabled

People

(Reporter: arai, Assigned: efaust)

References

Details

Attachments

(2 files)

Attached file use-strict2.binjs
encoded from
https://searchfox.org/mozilla-central/source/js/src/jit-test/tests/binast/nonlazy/basic/write-frozen-dense-strict.binjs

tested on m-c 6f8701d1be0c + patches for other bug fixes under bug 1495611

Configure flags: --enable-warnings-as-errors --disable-optimize --enable-debug

Runtime flag: -B use-strict2.binjs

Actual result:
Assertion failed: got false, expected true

Expected result:
no assertion failure

similar to bug 1497781, but this time there's no function.
(In reply to Tooru Fujisawa [:arai] from comment #0)
> Created attachment 9015785 [details]
> use-strict2.binjs
> 
> encoded from
> https://searchfox.org/mozilla-central/source/js/src/jit-test/tests/binast/
> nonlazy/basic/write-frozen-dense-strict.binjs

https://searchfox.org/mozilla-central/source/js/src/jit-test/tests/basic/write-frozen-dense-strict.js
Duplicate of this bug: 1497781
Assignee: nobody → efaustbmo
Status: NEW → ASSIGNED
Attachment #9016094 - Flags: review?(arai.unmht)
Comment on attachment 9016094 [details] [diff] [review]
Make script toplevel "use strict" effective.

Review of attachment 9016094 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9016094 - Flags: review?(arai.unmht) → review+
Depends on: 1497446
Pushed by efaustbmo@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cbd3b405f0e2
Correctly implement toplevel "use strict" in BinAST. (r=arai)
https://hg.mozilla.org/mozilla-central/rev/cbd3b405f0e2
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.