Closed Bug 1497820 Opened Last year Closed Last year

The "Magnifying Glass" icon from the "about:config" page's "Search" field is wrongly displayed

Categories

(Toolkit :: Themes, defect, P1)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- verified

People

(Reporter: mcoman, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- Firefox 64.0a1 Build ID - 20181009220508

[Affected Platforms]:
- All Mac

[Prerequisites]:
- Have a new Firefox profile.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Navigate to the "about:config" page and click the "I accept the risk!" button.
3. Observe the left part of the "Search" field.

[Expected result]:
- The "Magnifying Glass" icon is correctly displayed and aligned.

[Actual result]:
- The "Magnifying Glass" icon is displayed right near the left margin of the "Search" field.

[Regression window]:
Last good revision: f25bc716b4cd5a813536b7d469661f33aa004310
First bad revision: 96b560cb7df38a4427637dd839be05c2e25276a2
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f25bc716b4cd5a813536b7d469661f33aa004310&tochange=96b560cb7df38a4427637dd839be05c2e25276a2

Form the pushlog it looks that Bug 1473927 has caused the regression.

[Notes]:
- This issue is not reproducible on Windows and Linux.
- Attached a screenshot of the issue.
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: -- → P1
Duplicate of this bug: 1498243
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1f35618c6e3c
Get rid of the 'compact' class for search textboxes. r=paolo
https://hg.mozilla.org/mozilla-central/rev/1f35618c6e3c
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
I have reproduced this issue using Firefox 64.0a1 (2018.10.10) on Mac OS X 10.13.6.
I can confirm this issue is fixed, I verified using Firefox 64.0b3 on Mac OS X 10.13.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.