franklin.edu - Javascript drop-down menus will not form

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Dave, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
BuildID:    20020530

When logging into the online courses, a menu bar appears at the top. It uses 
Javascript (I believe). It does not work in Mozilla 1.0 (or previous builds), 
Netscape 6, or Netscape 7 preview, so it is likely with the rendering engine. 
Holding the mouse over the menu will invoke javascript:void(0), and this will 
create a drop-down menu with options to choose from. This menu never drops 
down, but that javascript line does appear in the status bar. HTML is in 
additional information section.

Reproducible: Always
Steps to Reproduce:
Sinple access the web page.

Actual Results:  No drop down menu appears

Expected Results:  Form drop-down menus with selectable options

When logging into the online courses, a menu bar appears at the top. It uses 
Javascript (I believe). It does not work in Mozilla 1.0 (or previous builds), 
Netscape 6, or Netscape 7 preview, so it is likely with the rendering engine. 
Holding the mouse over the menu will invoke javascript:void(0), and this will 
create a drop-down menu with options to choose from. This menu never drops 
down, but that javascript line does appear in the status bar. 

Here is the exact code which forms the drop down menus:







<html>
<head>
<title>Course Navigation for mis 430-v1ww</title>

<script LANGUAGE="JavaScript" src="/common/js/openNewWin.js">
</SCRIPT>
<script LANGUAGE="JavaScript" src="/common/js/openNewToolBarWin.js">
</SCRIPT>

<script LANGUAGE="JavaScript">
<!--
     NS4 = (document.layers);
     IE4 = (document.all);
    ver4 = (NS4 || IE4);
   isMac = (navigator.appVersion.indexOf("Mac") != -1);
  isMenu = (NS4 || (IE4 && !isMac));
  function popUp(){return};
  function popDown(){return};
  function startIt(){return};
  if (!ver4) event = null;

  if (isMenu) {
menuVersion = 3;
menuWidth = 140;
borWid = 2;
borSty = "solid";
borCol = "#000099";
separator = 1;
separatorCol = "#A9A9A9";
fntFam = "Verdana,sans-serif";
fntBold = false;
fntItal = false;
fntSiz = 8;
fntCol = "#0000FF";
overFnt = "#0000FF";
itemPad = 3;
backCol = "#EFEFEF"; //"#FFFFE0";
overCol = "#00EFCE";
imgSrc = "/images/c2k/nav/triangle.gif";
imgSiz = 10;

childOffset = 5;
childOverlap = 50;
perCentOver = null;

clickStart = false;
clickKill = false;
secondsVisible = 0.5;

keepHilite = true;
NSfontOver = false;

isFrames = true;
navFrLoc = "top";
mainFrName = "main";
  }

function guestAlert()
{
   alert("The menu item you have chosen is not accessible to users who are " +
         "logged in as \"guest\". \n\n" +
         "To aid you in visually determining which items are accessible " +
         "to guests and which are not, the menu items which are NOT " +
         "accessible to guests are marked with a preceding \"-\".  ");
}


//-->
</SCRIPT>




<script language="javascript1.2">



var courseType = "online15-2b"
var startPath  = "/mis/430/online15-2b/"
var faqType = "online"





arMenu1 = new Array(
"",
"207","",
"","",
"","",
"","",
"Syllabus",             startPath + "syll.jsp",1,
"Introduction",         startPath + "intro.jsp",0,
"Professor Information","/common/fachomepages/facpage.jsp?prof=earnshaw",0,
"Course Manager",       "/common/general/coursemgr.jsp", 0,
"FAQ",                  "/common/general/" + faqType + "faq.jsp",0,
"Help",                 "/common/general/techfaqs.jsp",0,
"Life-Long Learning Outcomes", "/common/general/l3outcomes.jsp",0,
"Student Info Form",    "javascript:openNewWin
('/common/forms/studinfoform.jsp','studentInfoWin')",0


,
"Course Evaluation",    "javascript:openNewWin
('/common/forms/onlineCourseevalS02on.jsp', 'courseEvalWin')",0





);

arMenu1_1 = new Array(
"Course Description",  startPath + "syll.jsp#sylHeader1"   ,0,
"Prerequisites",  startPath + "syll.jsp#sylHeader2"   ,0,
"Outcomes",  startPath + "syll.jsp#sylHeader3"   ,0,
"Required Materials",  startPath + "syll.jsp#sylHeader4"   ,0,
"Optional Materials",  startPath + "syll.jsp#sylHeader5"   ,0,
"Communications",  startPath + "syll.jsp#sylHeader6"   ,0,
"Student Responsibilities",  startPath + "syll.jsp#sylHeader7"   ,0,
"Grading Policy",  startPath + "syll.jsp#sylHeader8"   ,0,
"Submission & Return Policy",  startPath + "syll.jsp#sylHeader9"   ,0,
"Schedule", startPath + "syll.jsp#sylHeader10"  ,0,
"Academic Integrity", startPath + "syll.jsp#sylHeader11"  ,0,
"Academic Support", startPath + "syll.jsp#sylHeader12"  ,0,
"Accommodations for Disabilities", startPath + "syll.jsp#sylHeader13"  ,0
);


arMenu2 = new Array(
"",
"336","",
"","",
"","",
"","",
"Schedule",startPath + "sched.jsp",0,




      "Module 1","/mis/430/online15-2b/mod1.jsp",1,

      "Module 2","/mis/430/online15-2b/mod2.jsp",1,

      "Module 3","/mis/430/online15-2b/mod3.jsp",1,

      "Module 4","/mis/430/online15-2b/mod4.jsp",1,

      "Module 5","/mis/430/online15-2b/mod5.jsp",1,

      "Module 6","/mis/430/online15-2b/mod6.jsp",1,





"Resources", "javascript:void(0);",1

);



    arMenu2_2 = new Array(
    "Learning Outcomes", startPath + "mod1.jsp#header1"   ,0,
    "Introduction", startPath + "mod1.jsp#header2"   ,0,
    "Key Points", startPath + "mod1.jsp#header3"   ,0,
    "Enrichment", startPath + "mod1.jsp#header5"   ,0,
    "Assignment", startPath + "mod1.jsp#header7"   ,0
    )


    arMenu2_3 = new Array(
    "Learning Outcomes", startPath + "mod2.jsp#header1"   ,0,
    "Introduction", startPath + "mod2.jsp#header2"   ,0,
    "Key Points", startPath + "mod2.jsp#header3"   ,0,
    "Enrichment", startPath + "mod2.jsp#header5"   ,0,
    "Assignment", startPath + "mod2.jsp#header7"   ,0
    )


    arMenu2_4 = new Array(
    "Learning Outcomes", startPath + "mod3.jsp#header1"   ,0,
    "Introduction", startPath + "mod3.jsp#header2"   ,0,
    "Key Points", startPath + "mod3.jsp#header3"   ,0,
    "Enrichment", startPath + "mod3.jsp#header5"   ,0,
    "Assignment", startPath + "mod3.jsp#header7"   ,0
    )


    arMenu2_5 = new Array(
    "Learning Outcomes", startPath + "mod4.jsp#header1"   ,0,
    "Introduction", startPath + "mod4.jsp#header2"   ,0,
    "Key Points", startPath + "mod4.jsp#header3"   ,0,
    "Enrichment", startPath + "mod4.jsp#header5"   ,0,
    "Assignment", startPath + "mod4.jsp#header7"   ,0
    )


    arMenu2_6 = new Array(
    "Learning Outcomes", startPath + "mod5.jsp#header1"   ,0,
    "Introduction", startPath + "mod5.jsp#header2"   ,0,
    "Key Points", startPath + "mod5.jsp#header3"   ,0,
    "Enrichment", startPath + "mod5.jsp#header5"   ,0,
    "Assignment", startPath + "mod5.jsp#header7"   ,0
    )


    arMenu2_7 = new Array(
    "Learning Outcomes", startPath + "mod6.jsp#header1"   ,0,
    "Introduction", startPath + "mod6.jsp#header2"   ,0,
    "Key Points", startPath + "mod6.jsp#header3"   ,0,
    "Enrichment", startPath + "mod6.jsp#header5"   ,0,
    "Assignment", startPath + "mod6.jsp#header7"   ,0
    )






arMenu2_8 = new Array(

  "Library",    "javascript:openNewToolBarWin
('http://www.franklin.edu/students/library','ext')",0,

  "Turnitin.com", "/common/general/turnitin/turnitinStudent.jsp", 0





);


arMenu3 = new Array(
"",
"465","",
"","",
"","",
"","",
"Bulletin Board","javascript:openNewToolBarWin
('http://bboards.franklin.edu/courses/forumdisplay.php?
forumid=1666','bboardWin')",0,
"Chat Rooms","/common/chat/chatlaunch.jsp",0,

     "Instructor E-mail","mailto:earnshak@franklin.edu",0,

"Class E-mail","javascript:openNewWin
('/common/general/courseemail.jsp','emailpageWin')",0,
"Whiteboard","/common/whiteboard/whiteboardlaunch.jsp",0,


  "Announcements","javascript:openNewWin
('/common/messages/viewAllMessages.jsp','viewAllMsg')",0



);






arMenu4 = new Array(
"",
"595","",
"","",
"","",
"","",
"Grading Policies",   startPath + "gradepolicy.jsp"   ,0,
"Academic Integrity", startPath + "integrity.jsp" ,0,


   

    
        
             "Your Grades","javascript:openNewWin
('/common/grades/studViewGrades.jsp','gradeWin')" ,0
         
    
    
    

);




</script>





<script LANGUAGE="JavaScript1.2">
<!--
  if (isMenu) {
  document.write("<SCRIPT LANGUAGE='JavaScript1.2' 
SRC='/common/js/hierMenus.js'><\/SCRIPT>");
  }
//-->
</SCRIPT>
<script language="javascript" src="/common/js/browserCheck.js">

</script>
<script language="javascript"><!--
// 

is = new BrowserCheck()

function findWH() {
//   leftVar = (NS4) ? 9 : 16;
//   midVar = (NS4) ? 9 : 16;
//   rightVar = (NS4) ? 9 : 17;

   leftVar =  9;
   midVar =  9;
   rightVar = 9;

   if(!is.min) return;

   winW = (is.ns)? window.innerWidth : document.body.offsetWidth-20
   winH = (is.ns)? window.innerHeight : document.body.offsetHeight-4
   if(winW > 780)
   {  remainingSpace = winW - 780;
      if(IE4) remainingSpace += 20;
      leftVar  += (remainingSpace/4);
      midVar   += (remainingSpace/4);
      rightVar += (remainingSpace/2);

      arMenu1[1] = parseInt(arMenu1[1]) + (remainingSpace/2);
      arMenu2[1] = parseInt(arMenu2[1]) + (remainingSpace/2);
      arMenu3[1] = parseInt(arMenu3[1]) + (remainingSpace/2);
      arMenu4[1] = parseInt(arMenu4[1]) + (remainingSpace/2);

   }

}

function makeLiquid() {
   if ((is.ns && (winW!=window.innerWidth || winH!=window.innerHeight))
        || is.ie)
   {  menuLoc.location.reload()
      history.go(0)
   }
}



// -->
</script>

<style>
<!--
#top1{position:absolute; left:8; top:6;}
-->
</style>


</head>


<body background="/images/c2k/paper.jpg" bgcolor="#FFFFFF">


<div id="top1" align="left">

<script language="javascript"><!-- //
findWH();
var tableRow1 = "<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\">\n" +
  "<tr>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><img 
src=\"/images/c2k/nav/navleftend.gif\" width=\"14\" height=\"60\"></td>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><img src=\"/images/c2k/nav/navvar.gif\" 
width=\"" + leftVar + "\" height=\"60\"></td>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><a href=\"http://www.franklin.edu\" 
target=\"_top\"><img src=\"/images/c2k/nav/navlogo.gif\" width=\"133\" 
height=\"60\"\n" +
  "  alt=\"Franklin University\" border=\"0\"></a></td>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><img src=\"/images/c2k/nav/navvar.gif\" 
width=\"" + midVar + "\" height=\"60\"></td>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><img 
src=\"/images/c2k/nav/navleftsilver.gif\" width=\"38\" height=\"60\"></td>\n" +
  "  <td valign=\"top\" colspan=\"8\"><img 
src=\"/images/c2k/nav/coursenames/mis430.gif\" width=\"544\" height=\"33\"\n" +
  "  alt=\"mis 430-v1ww\"></td>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><img src=\"/images/c2k/nav/navvar.gif\" 
width=\"" + rightVar + "\" height=\"60\"></td>\n" +
  "  <td valign=\"top\" rowspan=\"2\"><img 
src=\"/images/c2k/nav/navrightend.gif\" width=\"7\" height=\"60\"></td>\n" +
  "</tr>\n";
  
var tableRow2 =   
  "<tr>\n" +
  "  <td valign=\"top\" height=\"32\"><a href=\"javascript:void(0)\"" +
  "         onMouseOver=\"popUp('elMenu1',event)\" " +
  "         onMouseOut=\"popDown('elMenu1')\"><img " +

  "         src=\"/images/c2k/nav/navoverview.gif\" border=\"0\" width=\"124\" 
height=\"27\" "+
  "         alt=\"About the Course\"></a></td>\n" +
  "  <td valign=\"top\"><img src=\"/images/c2k/nav/navsilversep.gif\" width=\"5
\" height=\"27\"></td>\n" +
  "  <td valign=\"top\"><a href=\"javascript:void(0)\"  " +
  "         onMouseOver=\"popUp('elMenu2',event)\" " +
  "         onMouseOut=\"popDown('elMenu2')\"><img " +
  "         src=\"/images/c2k/nav/navinstruction.gif\" border=\"0\" width=\"124
\" height=\"27\" " +
  "         alt=\"Materials\"></a></td>\n" +
  "  <td valign=\"top\"><img src=\"/images/c2k/nav/navsilversep.gif\" width=\"5
\" height=\"27\"></td>\n" +
  "  <td valign=\"top\"><a href=\"javascript:void(0)\"  " +
  "         onMouseOver=\"popUp('elMenu3',event)\" " +
  "         onMouseOut=\"popDown('elMenu3')\"><img " +
  "         src=\"/images/c2k/nav/navcommg.gif\" border=\"0\"  width=\"125\" 
height=\"27\" " +
  "         alt=\"Communications\"></a></td>\n" +
  "  <td valign=\"top\"><img src=\"/images/c2k/nav/navsilversep.gif\" width=\"5
\" height=\"27\"></td>\n" +
  "  <td valign=\"top\"><a href=\"javascript:void(0)\"  " +
  "         onMouseOver=\"popUp('elMenu4',event)\" " +
  "         onMouseOut=\"popDown('elMenu4')\"><img " +
  "         src=\"/images/c2k/nav/navgradeg.gif\" border=\"0\"  width=\"124\" 
height=\"27\" " +
  "         alt=\"Gradebook\"></a></td>\n" +
  "  <td valign=\"top\"><img src=\"/images/c2k/nav/navrightbottsilverg.gif\" 
width=\"32\" height=\"27\"></td>\n" +
  "</tr>\n" +
"</table>\n";

document.write(tableRow1);
document.write(tableRow2);
// --> </script>

</div>
</body>
</html>

Comment 1

16 years ago
Looks like it could be tech evangelism. If so, the site is in Ohio, United States. 

We can tell the site that HierMenus has an upgrade that works with Mozilla and
Netscape 6+. 
Component: Browser-General → JavaScript Engine

Comment 2

16 years ago
--> DOM Level 0 for triage.
Component: JavaScript Engine → DOM Level 0

Comment 3

16 years ago
reassigning to owner
Assignee: Matti → jst
QA Contact: imajes-qa → desale

Comment 4

16 years ago
hierMenus.js was never upgraded here
http://online.franklin.edu/common/js/hierMenus.js
Assignee: jst → doron
Status: UNCONFIRMED → NEW
Component: DOM Level 0 → US Edu
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: desale → caillon
Version: other → unspecified

Updated

16 years ago
Summary: Javascript drop-down menus will not form → franklin.edu - Javascript drop-down menus will not form

Comment 5

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
Component: US Edu → English US
QA Contact: z-caillon-obsolete2 → english-us

Comment 6

15 years ago
site no longer uses hiermenus.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.