Option to opt out of reboot in uninstaller is not shown

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
7 months ago
7 months ago

People

(Reporter: oana.botisan, Assigned: mhowell)

Tracking

({regression})

Trunk
Firefox 64
All
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 fixed, firefox64 verified, firefox65 verified)

Details

Attachments

(2 attachments)

Posted file Mozilla Firefox.zip
[Affected versions]:
- Firefox 62.0.3
- Beta 63.0b13
- Nightly 64.0a1.

[Affected platforms]:
- Windows 10 x64 
- Windows 7 x64

[Prerequisites]:
- Download the "Mozilla Firefox" file attached to this issue and save it in Program Files. 

[Steps to reproduce]:
1. Download Stub Installer for beta or .exe for Nightly.
2. Install Firefox.
3. Uninstall Firefox. 

[Expected result]:
- Firefox is successfully uninstalled and the system is not required to be rebooted. 
- The uninstall window looks like this: https://imgur.com/a/HhFocZX . 

[Actual result]:
- On beta 63.0b13 and on Nightly the uninstall window looks like this: https://imgur.com/a/ogrBSkr
- The user has no other choise than to restart the computer (or close the process from Task Manager). 

[Additional notes]:
- On Firefox 62.0.3 and earlier builds  the uninstall window looks like this: https://imgur.com/a/cMQ5qhC

- If you try to install Firefox 62.0 again and you didn't restart the computer before, this error is displayed on the screen: https://imgur.com/a/NR5JVkl
- There is no other process regarding Firefox in Task Manager except the uninstall wizard.
Assignee

Comment 1

7 months ago
There are two problems here:
1) The presence of defaults/pref/autoconfig.js is triggering the reboot flag. It shouldn't do that, the file should just be left alone.
2) The uninstall survey checkbox is interfering with the radio button that allows opting out of the reboot and causing that button to not be shown.

The second problem is the more pressing one because autoconfig.js isn't commonly found on user machines, so I'll work on it here and probably file a second bug for the part that's specific to autoconfig.js.
Assignee: nobody → mhowell
Blocks: 1448804
Status: NEW → ASSIGNED
Keywords: regression
Priority: -- → P1
Summary: Uninstalling Firefox is rebooting Windows if not all the Firefox folders were removed after a previous uninstall. → Option to opt out of reboot in uninstaller is not shown
Assignee

Updated

7 months ago
See Also: → 1498044

Comment 3

7 months ago
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b2ac40765b9
Don't accidentally hide the uninstaller reboot opt-out radio button. r=agashlin

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0b2ac40765b9
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
This is a regression and a P1, is it worth uplifting it to the Beta branch with the Fx63 RC build happening on Monday?
Flags: needinfo?(mhowell)
Assignee

Comment 6

7 months ago
I think it would be, I'll fill out the request.
Flags: needinfo?(mhowell)
Assignee

Comment 7

7 months ago
Comment on attachment 9016090 [details]
Bug 1497907 - Don't accidentally hide the uninstaller reboot opt-out radio button. r=agashlin

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1448804

User impact if declined: Users are not able to opt out of rebooting at the end of the uninstaller if a reboot is needed to finish the process.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: See comment 0. This patch doesn't cause the reboot prompt to not appear at all for those STR (that's bug 1498044), it just enables opting out of it.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This is a tiny (and, really, cosmetic) patch to code that only runs after the end of the uninstall procedure.

String changes made/needed:
Attachment #9016090 - Flags: approval-mozilla-beta?
Comment on attachment 9016090 [details]
Bug 1497907 - Don't accidentally hide the uninstaller reboot opt-out radio button. r=agashlin

P1 regression, verified  nightly, approved for the 63 beta branch. Thanks.
Attachment #9016090 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified the fix using the latest Nightly 65.a1 on Windows 10 and the bug is fixed partially. It doesn't ask me to reboot after I uninstall Nightly, but it does ask me for a restart when I try to install another Firefox version. 

And when I used beta 64.0b4 I still got the prompt with the reboot option in it, https://imgur.com/a/cMQ5qhC.
Assignee

Comment 11

7 months ago
I think that's expected because bug 1498044 is still not fixed; I filed it separately from this bug because that part of the fix is not as high of a priority.
I verified the fix using the stub installer for beta 64.0b6 and .exe file for Nightly 65.0a1 on Windows 10 x64 and Windows 7x64. The issue is not reproducing anymore, except the one I mentioned in comment 10, but that one I will track in bug 1498044.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.