Make nsDocShellLoadState take nsURI as a constructor argument

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P2
normal
RESOLVED FIXED
8 months ago
6 months ago

People

(Reporter: qdot, Assigned: qdot)

Tracking

(Blocks 1 bug)

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(2 attachments)

Can't have a nsDocShellLoadState without a URI to load, so might as well make that a requirement for construction.
Priority: -- → P2
Status: NEW → ASSIGNED
Duplicate of this bug: 1511192
Depends on: 1496251
We'll always need a URI for DocShellLoadState, and it should never
change. Construct the object with it and remove the mutator function.
We can't have null URIs now, so remove checks.

Depends on D13490

Comment 4

6 months ago
Pushed by kmachulis@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/63e0af38669e
Make URI a constructor argument of nsDocShellLoadState; r=bzbarsky
https://hg.mozilla.org/integration/autoland/rev/70996d85e8be
Remove URI null checks in nsDocShell::InternalLoad; r=bzbarsky

Comment 5

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/63e0af38669e
https://hg.mozilla.org/mozilla-central/rev/70996d85e8be
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.