Closed Bug 1498020 Opened 4 years ago Closed 4 years ago

Automatically open Reader Mode as dark if dark theme is enabled

Categories

(Toolkit :: Reader Mode, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: itiel_yn8, Unassigned)

References

Details

Nothing much to explain, I think it makes sense to automatically launch Reader Mode as dark if Firefox's theme is set to dark.
The minority of users who'd like to read with bright background can always change that if they want.
(In reply to Itiel from comment #0)
> Nothing much to explain, I think it makes sense to automatically launch
> Reader Mode as dark if Firefox's theme is set to dark.
> The minority of users who'd like to read with bright background can always
> change that if they want.

This is non-trivial, because you effectively end up with 2 controls (for the "global" and the "reader mode" theme), and you're saying that 1 of those should follow the other, and yet users should still be able to set it separately. This would likely require UI changes (ie how do you represent the "automatic" state in the UI in reader mode), and of course it's not clear whether to associate either the default or the 'sepia' theme in reader mode with either the default or the 'light' theme for the browser.

The other alternative would be to remove the ability to configure this separately, remove the 'sepia' mode, and always show the corresponding theme, which also seems like a loss of functionality. 

Given that users can just manually configure this with 2 clicks, and that makes things essentially work unless you change themes very frequently, I don't think we should complicate the settings here.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Silly me, I forgot that whatever the user selects in the reader mode options (Dark/Light/Sepia) stay that way, so this is not really relevant.
Sorry for the noise!
Duplicate of this bug: 1579543
You need to log in before you can comment on or make changes to this bug.