Closed Bug 1498075 Opened Last year Closed Last year

Print progress bar is broken and Print Dialog is too wide

Categories

(Toolkit :: XUL Widgets, defect)

64 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1497837

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached video Screencast (obsolete) —
Reproducible: always

Steps To Reproduce:
1. Print

Actual Results:
Print Progress dialog is too wide.
Print Progress bar is too wide when it is undetermined state
See attached screencast
Summary: Print progress bar is broken → Print progress bar is broken and Print Dialog is too wide
[Tracking Requested - why for this release]: Regression Print Dialog

There is 2 regression.
#1, Progress meter is always 100% and rendered top half.
#2, This Bug, Progress meter is too wide when undetermined state. and Print dialog is too wide.

#1 Regression window
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0438e11c91251842a22125cbab18f44ef265fa9b&tochange=5543e7f5ddadba11a98f54fef214089ea1f8f3a0

Regressed by: 5543e7f5ddad	Alexander Surkov — Bug 1491197 - replace progressmeter XBL binding by a custom element, r=paolo


#2 Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=150a7a5613b7cfc2adac4c801f29391c414042ff&tochange=ccbd30a9a23a7b979abb27211a095aa43d424bcc

Regressed by: ccbd30a9a23a	Alexander Surkov — Bug 1496189 - Password quality meter show always undetermined, r=paolo


@:asurkov,
Your patch causes the regression. Can you please look into this?
Blocks: 1496189
Flags: needinfo?(surkov.alexander)
"Cancel" button of the dialog will be pushing out to outside of screen.
Component: Printing: Output → XUL Widgets
Product: Core → Toolkit
Attachment #9016134 - Attachment is obsolete: true
Alice, could you please check whether bug 1497837 helps?
Flags: needinfo?(surkov.alexander) → needinfo?(alice0775)
(In reply to alexander :surkov (:asurkov) from comment #3)
> Alice, could you please check whether bug 1497837 helps?

Yes, the patch attachment 9016172 [details] [diff] [review] of bug 1497837 fixes this problem.

And I noticed another problem.
While printing in progress, the progress label and progress bar is working as expected.
However, when printing is finished, the progress label indicates as 100%, but the progressbar  returns empty like 0%.
I will file a new bug about this.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(alice0775)
Resolution: --- → DUPLICATE
Duplicate of bug: 1497837
You need to log in before you can comment on or make changes to this bug.