Closed Bug 1498084 Opened Last year Closed 11 months ago

add words to en-US.dic

Categories

(Core :: Spelling checker, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: ananuti, Assigned: ananuti)

References

(Blocks 1 open bug)

Details

User Story

accountabilities 
    SCOWL 3-stars & in en-US_large.

bizarro - Bizarre
    ‘Thanks (I think!) to a new fan for sending this bizarro thing to me.’
https://en.oxforddictionaries.com/definition/us/bizarro

customizable - Able to be modified to suit a particular individual or task.
    ‘The company offers customizable benefits packages.’
https://en.oxforddictionaries.com/definition/us/customizable

en masse - In a group, altogether.
    ‘the board of directors resigned en masse’
https://en.oxforddictionaries.com/definition/us/en_masse

gadzooks - an exclamation of excitement
    ‘What's so bizarre about members of the public, shock horror, enjoying a film with a storyline that can be followed on gadzooks! - one viewing without having to buy the accompanying crib notes?’
    ‘Older people have more time, more money, and now - gadzooks!’
https://en.oxforddictionaries.com/definition/us/Gadzooks

iatrogenesis,
iatrogenic - Relating to illness caused by medical examination or treatment.
    ‘drugs may cause side effects which can lead to iatrogenic disease’
https://en.oxforddictionaries.com/definition/us/iatrogenesis
https://en.oxforddictionaries.com/definition/us/iatrogenic

overbroad - Of an accent: too broad. rare.
https://en.oxforddictionaries.com/definition/us/overbroad

pro bono - Denoting work undertaken without charge, especially legal work for a client on low income.
    [as adverb] ‘the attorneys are representing him pro bono’
    [as adjective] ‘pro bono legal services’
https://en.oxforddictionaries.com/definition/us/pro_bono

Attachments

(1 file, 1 obsolete file)

No description provided.
Attached patch bug1498084.patch (obsolete) — Splinter Review
Attachment #9016137 - Flags: review?(ehsan)
Duplicate of this bug: 1498016
Duplicate of this bug: 1497127
Comment on attachment 9016137 [details] [diff] [review]
bug1498084.patch

Review of attachment 9016137 [details] [diff] [review]:
-----------------------------------------------------------------

::: extensions/spellcheck/locales/en-US/hunspell/en-US.dic
@@ +16924,5 @@
>  biweekly/SM
>  biyearly
>  biz/M
>  bizarre/Y
> +bizarro

I think this isn't a suitable addition to the spellchecker dictionary because it is a less common variant of "bizarre" and including it would run the chance of suggesting "bizarro" as a spelling suggestion where the user meant to type "bizarre".  This is another one of those cases where even though the word itself is a valid English word, adding it to a spellchecking dictionary will probably do more harm than good due to its similarity to another more commonly used word.

@@ +27607,5 @@
>  gadfly/SM
>  gadget/SM
>  gadgetry/M
>  gadolinium/M
> +gadzooks

gadzooks seems to be an archaic phrase, not used in modern English.  Not sure why you included it here?  It also appears to be used uppercase only.

My suggestion is to exclude it from the spellchecker dictionary.  This doesn't seem like a phrase that our users would commonly type in a textbox on a web page in modern times.
Attachment #9016137 - Flags: review?(ehsan) → review-
User Story: (updated)
delta: 
-bizarro
-gadzooks
+iatrogenesis
+iatrogenic
Attachment #9016137 - Attachment is obsolete: true
Attachment #9017409 - Flags: review?(ehsan)
Attachment #9017409 - Flags: review?(ehsan) → review+
Keywords: checkin-needed
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37d35eb84281
Add words to en-US dictionary. r=ehsan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/37d35eb84281
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.