Closed Bug 1498103 Opened 11 months ago Closed 10 months ago

[remote-dbg-next] Runtime page becomes blank when uninstalling ADB Extension

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox65 fixed)

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: jdescottes, Assigned: daisuke)

References

Details

Attachments

(4 files)

Follow up from Bug 1493104, Daisuke commented in the review (https://phabricator.services.mozilla.com/D7873#186648)

> 
> One thing. When uninstall the addon, the status will be weird a bit.
> STRs:
>    Install addon. (Connecting USB device will display)
>     Connect and select a USB device from list (Show runtime page for the USB device)
>     Uninstall addon. (Connecting USB device will hide from list)
>         issue: Runtime page will be blank. We need to address this by some ways.
>     Reinstall addon. (Connecting USB device will display again)
>         issue: The status of device which connected last time is already selecting. 
>         But "connect" button is displayed.
> 

Have not been able to reproduce initially, so flagging as unconfirmed for now.
Attached video 1498103-strs.mp4
Thank you for filing this!
Since still I could reproduce on today's m-c, I attach a video of this STRs.
Thanks for the video Daisuke. I could also reproduce the issue today, switching status to NEW.
Note that I also get a blank screen if I start WebIDE while showing the Runtime page for a USB device.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P2 → P1
When the addon was removed/added, REQUEST_EXTENSIONS_SUCCESS action was fired.
But because current USB runtime does not support extensions debugging, we
avoid to add debug target listener for USB runtime. Likewise, we refer the
state of supporting for workers and tabs.
So far, when USB list was updated, since we replace to all new instances, the
states had not been able to keep. To resolve this, re-use runtimes that retain
in runtimes state.

Depends on D9470
Blocks: 1501164
Blocks: 1501192
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28ab0061c2ac
Avoid to add debug target listeners for USB runtime. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/eca6ed1ae9ad
Select 'this firefox' page when selected runtime was removed. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/8523f4a3ba87
Use existing USB runtime to keep current state. r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/28ab0061c2ac
https://hg.mozilla.org/mozilla-central/rev/eca6ed1ae9ad
https://hg.mozilla.org/mozilla-central/rev/8523f4a3ba87
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Blocks: 1503914
You need to log in before you can comment on or make changes to this bug.