Read Only calendar all day end date one day too long in dialog

RESOLVED FIXED in 6.2.3

Status

defect
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: joerg.schmauder, Assigned: MakeMyDay)

Tracking

Lightning 5.4
6.2.3

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

I set calendars to read only (right click on calendar -> Properties -> Check "Read Only").


Actual results:

if double clicking on a all-day event the end date is one day too late. if only hovering over the event with the mouse pointer the end date is displayed correctly. when unchecking "Read Only" in the edit dialog the end date is displayed correctly.


Expected results:

the end date should be displayed correctly.

i tested on local calendars, CalDAV and iCal calendars, no difference there. tested on two systems:

system 1: linux mint 18, tb 52.9.1 (64bit), lightning 5.4
system 2: windows 7 pro, tb 52.9.1 (32bit), lightning 5.4.9.1

no difference there. the following bug might be related:
https://bugzilla.mozilla.org/show_bug.cgi?id=1092554

this historic bug report is also about wrong end dates:
https://bugzilla.mozilla.org/show_bug.cgi?id=332268
Confirming. The attached patch takes care.

The fix of the getter is unrelated - just doing it when touching that code, though it shouldn't matter since we don't use it anyway.
Assignee: nobody → makemyday
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9016290 - Flags: review?(philipp)
Attachment #9016290 - Flags: approval-calendar-esr?(philipp)
Attachment #9016290 - Flags: approval-calendar-beta?(philipp)
Duplicate of this bug: 1092554
Attachment #9016290 - Flags: review?(philipp)
Attachment #9016290 - Flags: review+
Attachment #9016290 - Flags: approval-calendar-esr?(philipp)
Attachment #9016290 - Flags: approval-calendar-esr+
Attachment #9016290 - Flags: approval-calendar-beta?(philipp)
Attachment #9016290 - Flags: approval-calendar-beta+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9d0f37068236
All-day items are displayed one day too long in summary dialog. r=philipp
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.6
TB 60.3 ESR, Cal 6.2.3.
https://hg.mozilla.org/releases/comm-esr60/rev/f72298a7ddc6fab588b86e566ddfe99e7fdd3330

Need to fix the target here.
Flags: needinfo?(makemyday)
Target Milestone: 6.6 → 6.2.2
Yes, we still need to update the milestones - just add a whiteboard comment like this for the moment, I'll take care of updateing the targets later when we have it.
Flags: needinfo?(makemyday)
Whiteboard: [update taget milestone: 6.3]
Whiteboard: [update taget milestone: 6.3] → [update taget milestone: 6.2.3]
Comment on attachment 9016290 [details] [diff] [review]
WrongEndDateForAllDayItemsInSummaryDialog-V1.diff

Too late for 63/6.5 beta now.
Attachment #9016290 - Flags: approval-calendar-beta+
Whiteboard: [update taget milestone: 6.2.3]
Target Milestone: 6.2.2.1 → 6.2.3
You need to log in before you can comment on or make changes to this bug.