File->Save Page As crashes Mozilla when saving multiple tabs

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
11 years ago

People

(Reporter: geuzaine, Assigned: jag+mozilla)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

File->Save Page As crashes Mozilla when saving multiple tabs.

Reproducible: Always
Steps to Reproduce:
1.Open http://www.themareks.com/xf/prehistory.shtml
2.Open http://www.themareks.com/xf/1997.shtml in a new tab
3.Open http://www.themareks.com/xf/1998.shtml in a new tab
4.Open http://www.themareks.com/xf/1999.shtml in a new tab
5.Open http://www.themareks.com/xf/2000.shtml in a new tab
6.Open http://www.themareks.com/xf/2001.shtml in a new tab
7.Try File->Save Page As in tab 1
8.Try File->Save Page As in tab 2
9.Try File->Save Page As in tab 3
10.Try File->Save Page As in tab 4
11.Try File->Save Page As in tab 5
12.Try File->Save Page As in tab 6

Actual Results:  Mozilla crashes, sometimes while saving the second tab,
sometimes while saving the third... but always before saving the last one.

Expected Results:  Mozilla shouldn't crash...

If you open and save the files one at a time (i.e. not using tabs), everything
works fine.

Note that the problem is not peculiar to the set of pages mentioned above: I was
able to reproduce the bug with many other web pages. The only difference is that
it usually occurs later: you may have to open many more tabs (e.g. 20), and
Mozilla might only crash when saving tab #13...

Comment 1

17 years ago
worksforme with linux trunk build 20020606

crash bugs are critical, adding keyword.
Severity: normal → critical
Keywords: crash
WFM with trunk 2002073022, linux. reporter: can you reproduce this bug with a
recent build of mozilla (for example, 1.1beta)? if so, please comment again with
details. if not, please resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 3

17 years ago
Seems to work with recent builds (tested with trunk 2002080508). Changing
resolution to WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.