Closed Bug 1498284 Opened Last year Closed Last year

./mach anything fails with "AttributeError: 'module' object has no attribute 'DirEntry'"

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1498215

People

(Reporter: keeler, Unassigned)

References

Details

keeler@p710 ~/mozilla-unified $ ./mach help
Traceback (most recent call last):
  File "./mach", line 86, in <module>
    main(sys.argv[1:])
  File "./mach", line 78, in main
    mach = get_mach()
  File "./mach", line 68, in get_mach
    mach = check_and_get_mach(dir_path)
  File "./mach", line 42, in check_and_get_mach
    return load_mach(dir_path, mach_path)
  File "./mach", line 30, in load_mach
    return mach_bootstrap.bootstrap(dir_path)
  File "/home/keeler/mozilla-unified/build/mach_bootstrap.py", line 320, in bootstrap
    driver.load_commands_from_file(os.path.join(mozilla_dir, path))
  File "/home/keeler/mozilla-unified/python/mach/mach/main.py", line 267, in load_commands_from_file
    imp.load_source(module_name, path)
  File "/home/keeler/mozilla-unified/tools/lint/mach_commands.py", line 24, in <module>
    from scandir import scandir
  File "/home/keeler/mozilla-unified/build/mach_bootstrap.py", line 349, in __call__
    module = self._original_import(name, globals, locals, fromlist, level)
  File "/home/keeler/mozilla-unified/third_party/python/scandir/scandir.py", line 584, in <module>
    DirEntry_c = _scandir.DirEntry
AttributeError: 'module' object has no attribute 'DirEntry'

ec133330b1ec fails but 641b4a378923 works so I'm assuming this is due to bug 1481612.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1498215
You need to log in before you can comment on or make changes to this bug.