If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't select or delete leading empty lines in quotes

NEW
Unassigned

Status

()

Core
Editor
16 years ago
11 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Trunk
mozilla1.4beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Reproduction (not 100% reliable):
1. Use HTML editor in Mailnews
2. Reply to a normal plaintext email (as sent from 4.x, not Mozilla) with quotes
3. Interleave your replies in the quote and try to delete the nested quote of
level 2

Actual result:
- You end up with some leading vertical whitespace in the quote
- You cannot select it
- You cannot delete it or it is very hard to delete.

The empty lines sometimes have the same quote level as the text, sometimes they
are in nested quotes on their own.

Expected result:
- I can put the caret on the empty lines at the start of the quote. Hitting
Delete or Backspace there removes the current empty line.
- Putting the caret at the first column of the quoted text and pressing
backspace should remove the empty quoted line before it
- Similarily, putting the caret at the end of the line before the quote and
hitting Delete should remove the empty quoted line at the beginning of the quote.
- Ideally, you can select from the first column of the quoted text to the end of
the line before the quote (i.e. select just the quoted empty lines) and hit
Delete and that removes the empty lines.
(Reporter)

Comment 1

16 years ago
Created attachment 86761 [details]
Screenshot of a msg in that problematic state



This is a very old bug (it has always been there, IIRC) and annoying.

Interestingly, these empty lines are not there when I send the msg.
(Reporter)

Comment 2

16 years ago
> annoying

Actually, visible is the better word (once you know that the lines won't be
sent). I makes the editor feel buggy.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 127235 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
This is not necessarily a dup. I changed all the text to "Body Text", and I
still get those unremovable empty lines, although less of them.

sujay, please don't rubber-stamp verify bugs (esp. not those that I filed or
assigned to me). Thanks.

Comment 6

16 years ago
reopening: i want to make sure we examine this particular case.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

15 years ago
The days of having a half dozen milestones out in front of us to divide bugs 
between seem to be gone, though I dont know why.  Lumping everything together as 
far out as I can.  I'll pull back things that I am working on as I go.
Target Milestone: --- → mozilla1.2beta

Comment 8

15 years ago
migrating milestones now that there are more available.  i'll pull these back as
I work on them
Target Milestone: mozilla1.2beta → mozilla1.4beta
QA Contact: sujay → editor
Assignee: mozeditor → nobody
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.