File > Save As > File - doesn't overwrite existing file when replace was chosen

RESOLVED FIXED in Thunderbird 64.0

Status

defect
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: marcoagpinto, Assigned: jorgk)

Tracking

Thunderbird 64.0

Thunderbird Tracking Flags

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

Details

Attachments

(1 attachment)

Hello!

When I am composing a message and I drag and drop an image (tested with PNGs) into it, if I select: File > Save As > File, and the file untitled.html already exists, it asks if we want to overwrite it, I select yes, but it ignores the "yes" and keeps the old file.

Try doing this multiple times. It will always keep the old untitled.html .
Confirmed :-( - You don't need an image, just make something bold in the text so that it's saved as untitled.html. Actually, if you just enter unformatted text, the file untitled.txt isn't overwritten.

Alice, can you find the regression for us? It might be bug 1341211, especially
https://hg.mozilla.org/comm-central/rev/36bd1eaceefb
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alice0775)
Summary: File > Save As > File - doesn't overwrite html files → File > Save As > File - doesn't overwrite existing file when replace was chosen
Regression is here:
https://hg.mozilla.org/comm-central/rev/d361db344198#l1.13

Thanks, Alice!!!
Marco, thanks for reporting. We'll get it fixed in TB 60.3 in 10 days.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #9016967 - Flags: review?(acelists)
Comment on attachment 9016967 [details] [diff] [review]
1498483-allow-overwrite.patch

Review of attachment 9016967 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me.
Attachment #9016967 - Flags: review?(acelists) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/2df9fd956bec
saving current composition doesn't overwrite existing file. r=aceman
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Attachment #9016967 - Flags: approval-comm-esr60+
Attachment #9016967 - Flags: approval-comm-beta+
Duplicate of this bug: 1503539
You need to log in before you can comment on or make changes to this bug.