Closed Bug 1498536 Opened 3 years ago Closed 3 years ago

RDM - edit/add device list - highlight on tabbing

Categories

(DevTools :: Responsive Design Mode, defect, P2)

defect

Tracking

(firefox-esr60 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 wontfix)

RESOLVED DUPLICATE of bug 1325571
Tracking Status
firefox-esr60 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix

People

(Reporter: cfogel, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [dt-q])

Attachments

(2 files)

[Affected versions]:
- 64.0a1 (2018-10-11), 63.0b13, 62.0.3, 60.2.2esr;

[Affected platforms]:
- Win 10x64, macOS 10.13, Ubuntu 16.04

[Steps to reproduce]:
1. Launch Firefox;
2. Open the DevTools;
3. Click on the RDM button;
4. Click on the Responsive button;
5. Click inside any check-box;
6. Press the Tab key

[Expected result - enchancement]:
- each active/focus-ed option is marked *somehow;

[Actual result]:
- user cannot know which option is active unless space bar is pressed and an option is toggled;

[Regression range]:
- noticed that in older versions the active check-box had its outline dashed; 
- considering that implementation (even if not intended) good and current one bad, the pushlog result is found at the link bellow:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=60dd82380d43a2b681f50842238f829204486290&tochange=215f9686117673a2c914ed207bc7da9bb8d741ad


[Additional notes]:
- attached recording with the issue;
Attached image RDM_dashedCheckbox.png
Attached an image with an implementation from 2016-10-24 of that section, as mentioned in the regression section.
Whiteboard: [dt-q]
See Also: → 1487857
Happy to take a patch in nightly; if it seems low risk enough please feel free to request uplift to 65 beta.
Blocks: rdm-ux

I noticed that this bug is a duplicate of bug 1325571. I will close this one and carry over priority plus dt-q. Feel free to reopen the bug if you think this issue is different :)

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1325571
You need to log in before you can comment on or make changes to this bug.