Closed Bug 1498629 Opened Last year Closed Last year

pg docker image fails to build

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(firefox-esr60 fixed, firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr60 --- fixed
firefox64 --- fixed

People

(Reporter: dustin, Assigned: dustin)

References

Details

Attachments

(1 file)

[task 2018-10-12T16:07:32.018Z] Installing dependencies from Pipfile.lock (fa3ca8)…
[task 2018-10-12T16:07:36.252Z] An error occurred while installing backports-lzma==0.0.13 --hash=sha256:50829db66f0445442f6c796bba0ca62d1f87f54760c4682b6d1489e729a43744! Will try again.
[task 2018-10-12T16:07:44.809Z] Installing initially failed dependencies…
[task 2018-10-12T16:07:45.216Z] Collecting backports-lzma==0.0.13 
[task 2018-10-12T16:07:45.216Z] 
[task 2018-10-12T16:07:45.216Z]   Could not find a version that satisfies the requirement backports-lzma==0.0.13 (from -r /tmp/pipenv-n55a8ro9-requirements/pipenv-vlij2w3c-requirement.txt (line 1)) (from versions: )
[task 2018-10-12T16:07:45.216Z] No matching distribution found for backports-lzma==0.0.13 (from -r /tmp/pipenv-n55a8ro9-requirements/pipenv-vlij2w3c-requirement.txt (line 1))

The package appears to be called bakcports.lzma (. instead of -)
  https://pypi.org/project/backports.lzma/
This is caused by https://github.com/pypa/pipenv/issues/2956 which I'm hopeful will be in a release soon. Otherwise we should pin pipenv to a working version.
You are the best, Tom.
Assignee: nobody → dustin
No longer blocks: 1432390
Pushed by dmitchell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/726452883324
pin pipenv version temporarily to avoid bug r=tomprince
https://hg.mozilla.org/mozilla-central/rev/726452883324
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.