Closed Bug 149871 Opened 18 years ago Closed 18 years ago

recommend "Save page As"

Categories

(Core Graveyard :: File Handling, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 64286

People

(Reporter: tomliau33, Assigned: law)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When I want to save a page,(choose "Web Page, complete")
it always save to name.htm and <DIR>name_files!
Could mozilla save a page to a file?
example: MS-IE can save a page to *.mht, which include html and all pictures

I found that mozilla can browser html_file from a zip_file,
exp: jar:file:///htmlfile.zip!/file.html

I suggest that mozilla save a page to name.zht (zip of html, include html and
all pictures)

when user open a htmlfile.zht,
mozilla open it with "jar:file://htmlfile.zht!/index.html"
(if mozilla can analysis how many html_files in zht_file, and let user choose
which html to browse, it will more better)

If mozilla can add this features to next version, it is better than IE, because
.mht is not a compression file!


Reproducible: Didn't try
Steps to Reproduce:
1.Browser any web
2.Menu->File->Save Page As
See the following bugs for some related suggestions:

* bug 40873(RFE: Save as rfc 2557 MHTML; complete webpage in one file).  
* bug 18764(RFE: Full rfc2557 MHTML multipart/related support in BROWSER).  
* bug 64286([RFE] .zip, .tgz, .tar, or .jar archive off/on-line browsing)

Thanks Robert, I think this is a duplicate of bug 64286 as the requested
functionality is very similar.

Reporter: if you disagree, feel free to reopen, thanks for your suggestion

*** This bug has been marked as a duplicate of 64286 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
vrfy dupe of one of those bugs
Status: RESOLVED → VERIFIED
this is duplicate of bug 64286
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.