Update placeholder value of DNS over HTTPS input

RESOLVED FIXED in Firefox 63

Status

()

defect
P1
normal
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: ewright, Assigned: ewright)

Tracking

64 Branch
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed, firefox64 fixed)

Details

(Whiteboard: [trr])

Attachments

(3 attachments)

+++ This bug was initially created as a clone of Bug #1495583 +++

This is to change the placeholder in the DNS over HTTPS preferences pane to the cloudflare url.
To provide the user with at least a hint of which url they can use if they change it. This will be temporary until https://bugzilla.mozilla.org/show_bug.cgi?id=1495583 can land.
Summary: add restore default value to DNS-over-HTTPS preferences → Update placeholder value of DNS over HTTPS input
Update placeholder value of DNS over HTTPS input to the cloudflare provider add a default pref value for network.trr.uri
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b2dc8c549bc4
Update placeholder value of DNS over HTTPS input, add default pref value r=jduell
My apologies for stepping in here to review this last-minute. We really want this for 63 so we don't provide a useless example URI for DNS-over-HTTPS. Confident that our CTO agrees with me (and I'm double-checking with him)

(The patch we originally were going to uplift--bug 1495583--turned out to need localization. This doesn't, and is simpler too.)
Comment on attachment 9016883 [details]
bug 1498758 - Update placeholder value of DNS over HTTPS input, add default pref value

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: DNS-over-HTTPS preferences UX

User impact if declined: DNS-over-HTTPS is turned off in 63, but is available to enable in Preferences (General | Networking | enable DNS-over-HTTPS: I'll add a screenshot).  We're about to ship with a bogus 'example' URI as the default provider, which is Bad (it requires users to find and cut-and-paste a provider URI to get it working).   We want to instead default to the valid provider URI that we've already cut a business deal with to provide DNS-over-HTTPS for us.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Only changes default URI in about:config, and in some UX code

String changes made/needed:
Attachment #9016883 - Flags: approval-mozilla-beta?
To clarify comment 0: this patch also sets the trr.uri pref (i.e. it makes DNS-over-HTTPS work if a user enables it). So it's not just providing a suggestion.
https://hg.mozilla.org/mozilla-central/rev/b2dc8c549bc4
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9016883 [details]
bug 1498758 - Update placeholder value of DNS over HTTPS input, add default pref value

The patch is minimal has tests and is a clear UX improvement, I also verified that it works as intended on Nightly, let's take it before the merge.
Attachment #9016883 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.