Some MFBT tests don't run in automation

RESOLVED FIXED in Firefox 64

Status

()

enhancement
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: botond, Assigned: botond)

Tracking

unspecified
mozilla64
Points:
---

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment)

Some of the C++ unit tests in mfbt/tests are not running in automation.

To illustrate, I changed some tests to deliberately fail by adding a |MOZ_RELEASE_ASSERT(false)| to them, and pushed to Try:

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1&revision=66d812115762c9b469c0ee51477079c92d862471

and the Try push is green.

After some spelunking in the log of the "Cpp" test job to see what command it calls (testing/runcppunittests.py), and what that command does, I discovered that the problem is that only those tests listed in testing/cppunittest.ini [1] are run, and not all MFBT tests are listed there.

[1] https://searchfox.org/mozilla-central/source/testing/cppunittest.ini
See Also: → 1265033, 1266009
Also add a comment to mfbt/tests/moz.build to remind people that tests
need to be added to testing/cppunittest.py.
Assignee: nobody → botond
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b8d90d5901be
Add missing MFBT tests to testing/cppunittest.py. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/b8d90d5901be
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.