Closed Bug 1498827 Opened 2 years ago Closed 2 years ago

Permafailing browser/base/content/test/static/browser_all_files_referenced.js | Uncaught exception - [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChromeRegistry when Gecko 64 merges to Beta on 2018-10-15

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
geckoview62 --- unaffected
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 + verified

People

(Reporter: intermittent-bug-filer, Assigned: wisniewskit)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=205267915&repo=try

https://queue.taskcluster.net/v1/task/eb5yXPMwQFG3a0_XcwpYhA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-10-13T14:35:33.887Z] 14:35:33     INFO - TEST-START | browser/base/content/test/static/browser_all_files_referenced.js
[task 2018-10-13T14:35:36.351Z] 14:35:36     INFO - TEST-INFO | started process screentopng
[task 2018-10-13T14:35:36.833Z] 14:35:36     INFO - TEST-INFO | screentopng: exit 0
[task 2018-10-13T14:35:36.834Z] 14:35:36     INFO - Buffered messages logged at 14:35:33
[task 2018-10-13T14:35:36.834Z] 14:35:36     INFO - Entering test bound checkAllTheFiles
[task 2018-10-13T14:35:36.834Z] 14:35:36     INFO - Buffered messages finished
[task 2018-10-13T14:35:36.836Z] 14:35:36     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | Uncaught exception - [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChromeRegistry.convertChromeURL]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js :: getBaseUriForChromeUri :: line 258"  data: no]
[task 2018-10-13T14:35:36.836Z] 14:35:36     INFO - Stack trace:
[task 2018-10-13T14:35:36.837Z] 14:35:36     INFO - getBaseUriForChromeUri@chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:258:17
[task 2018-10-13T14:35:36.838Z] 14:35:36     INFO - trackChromeUri@chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:263:18
[task 2018-10-13T14:35:36.839Z] 14:35:36     INFO - parseManifest/<@chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:278:9
[task 2018-10-13T14:35:36.840Z] 14:35:36     INFO - Leaving test bound checkAllTheFiles
[task 2018-10-13T14:35:36.842Z] 14:35:36     INFO - Console message: No chrome package registered for chrome://webcompat-reporter/locale/gobbledygooknonexistentfile.reallynothere
[task 2018-10-13T14:35:36.843Z] 14:35:36     INFO - GECKO(1929) | JavaScript error: chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js, line 258: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChromeRegistry.convertChromeURL]
[task 2018-10-13T14:35:36.844Z] 14:35:36     INFO - Console message: [JavaScript Error: "NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChromeRegistry.convertChromeURL]" {file: "chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js" line: 258}]
[task 2018-10-13T14:35:36.846Z] 14:35:36     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-13T14:35:36.847Z] 14:35:36     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | A promise chain failed to handle a rejection: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChromeRegistry.convertChromeURL] - stack: getBaseUriForChromeUri@chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:258:17
[task 2018-10-13T14:35:36.848Z] 14:35:36     INFO - trackChromeUri@chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:263:18
[task 2018-10-13T14:35:36.849Z] 14:35:36     INFO - parseManifest/<@chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:278:9
[task 2018-10-13T14:35:36.850Z] 14:35:36     INFO - Rejection date: Sat Oct 13 2018 14:35:36 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
[task 2018-10-13T14:35:36.851Z] 14:35:36     INFO - Stack trace:
[task 2018-10-13T14:35:36.852Z] 14:35:36     INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
[task 2018-10-13T14:35:36.853Z] 14:35:36     INFO - chrome://mochikit/content/browser-test.js:nextTest:735
[task 2018-10-13T14:35:36.854Z] 14:35:36     INFO - chrome://mochikit/content/browser-test.js:testScope/test_finish/<:1387
[task 2018-10-13T14:35:36.855Z] 14:35:36     INFO - chrome://mochikit/content/browser-test.js:run:1324
[task 2018-10-13T14:35:36.856Z] 14:35:36     INFO - GECKO(1929) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
[task 2018-10-13T14:35:36.857Z] 14:35:36     INFO - GECKO(1929) | MEMORY STAT | vsize 773MB | residentFast 376MB | heapAllocated 202MB
[task 2018-10-13T14:35:36.858Z] 14:35:36     INFO - TEST-OK | browser/base/content/test/static/browser_all_files_referenced.js | took 2482ms
[task 2018-10-13T14:35:36.859Z] 14:35:36     INFO - checking window state
Duplicate of this bug: 1498828
Ugh. Looks I'll have to do that check as the system addons are loaded by checking its pref in isUsableAddon, rather than asynchronously during _onWindowsRestored: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b9a0885c545080aa783856c7f2febd222290ed62
Flags: needinfo?(wisniewskit)
Ensure the webcompat report addon is disabled upon load, if extensions.webcompat-reporter.enabled=false, take two
Alright, that try-run looks clean, so once I can find a reviewer to confirm there's nothing off about this, we should be good to land.
So it turns out that I also needed to update this fix to make sure it can enable the addon if it began its life disabled. Basically, setUserDisabled does not try to enable the addon if it doesn't see a difference in the values userDisabled or softDisabled, which doesn't happen for system addons that are triggered by pref right now. The easiest fix for now is to simply force it to check for system addons properly. I'd like to resolve the permafails in this way for now, until we can properly resolve these issues in bug 1489527.
Ugh, there's still a problem here. It seems that the test is looking for the hacky dynamically-injected locale files the addon is presently using (until bug 1425104 lands), but can't find them. I'll have to figure out how to have it skip them for now.
Alright, according to try my latest revision will do the trick: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d7693122c4fc929663cf02cb0380cdf21bdfe851&selectedJob=205693446

aswan, this patch just contains work-arounds for bug 1425104 (Fluent extension API) and bug 1489527 (better pref-based enabling/disabling of system addons). I don't know if it's worth putting extra effort into them given that those bugs are prioritized.
Assignee: nobody → wisniewskit
Priority: P5 → P1
Flags: needinfo?(aswan)
Alright, one last try-run shows that the patch aswan and I hashed out seems fine: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e973c1dfd6546268fd12044746bb0c8d772c5e67&selectedJob=205935566
Flags: needinfo?(aswan)
Thanks for the reviews, aswan, mixedpuppy!

Requesting check-in.
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/6191777b6e40
Ensure the webcompat report addon is disabled upon load, if extensions.webcompat-reporter.enabled=false, take two r=aswan,mixedpuppy
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/943c79ca40a9
Ensure the webcompat report addon is disabled upon load, if extensions.webcompat-reporter.enabled=false, take two: Lower minimum access for extensions.getAddons.cache.enabled CLOSED TREE
https://hg.mozilla.org/mozilla-central/rev/6191777b6e40
https://hg.mozilla.org/mozilla-central/rev/943c79ca40a9
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.