Shutting down TB when preferences were open causes malfunction after restart, reopening options tab doesn't highlight selected pane

RESOLVED FIXED in Thunderbird 64.0

Status

defect
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: jorgk, Assigned: darktrojan)

Tracking

Trunk
Thunderbird 64.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Shutting down TB when preferences were open in a tab makes pane selection unresponsive after restart.

STR:
Open preferences, select Display, Tags
Close TB
Start TB
Comes back with "General", no pane selected.
Try to switch pref pane.

Result: It doesn't work.

I've had cases where it came back with the Display pane, but General was selected. That's what it does when you select Display, Tags, then close the options tab and open it again.

Conclusion: Mileage varies, but it's buggy.

Tested with Calendar disabled.
Flags: needinfo?(geoff)
Tried this in official Daily of 2018-10-13, both are reproducible:
If you start with the Options tab open, pane selection doesn't work.
If you close options and re-open, the pane selection isn't right.
This wouldn't involve a radiogroup, would it? (Spoiler: it does.) Broken by bug 1481949.
Flags: needinfo?(geoff)
I don't quite know what the root cause is, but this fixes it.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9017057 - Flags: review?(jorgk)
Comment on attachment 9017057 [details] [diff] [review]
1498863-pref-pane-select-1.diff

One line fixes this annoying bug, thanks. That broke a while ago and no one complained :-( - I'll ship it now.
Attachment #9017057 - Flags: review?(jorgk) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/08a107c8c517
Fix broken remembering of selected preference pane after bug 1481949. r=jorgk DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
You need to log in before you can comment on or make changes to this bug.