Terminal warnings "Unknown widget type" when cursor passes over elements in toolbox

RESOLVED FIXED in Firefox 64

Status

()

P1
normal
RESOLVED FIXED
a month ago
10 days ago

People

(Reporter: ke5trel, Assigned: stransky)

Tracking

(Blocks: 1 bug, {regression})

64 Branch
mozilla65
Unspecified
Linux
regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 fixed, firefox65 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago
Since Bug 1498356, when the mouse cursor passes over different elements in the toolbox, the following warning appears repeatedly in the terminal:

> ** (firefox:3240): WARNING **: 18:04:15.167: Unknown widget type: 95

Updated

a month ago
status-firefox62: --- → unaffected
status-firefox63: --- → unaffected
I have the same problem with:

64.0a1 (2018-10-16) (64-bit)

status-firefox64: --- → affected

Updated

a month ago
Duplicate of this bug: 1499687
(Assignee)

Comment 3

29 days ago
That's because we introduced a MOZ_GTK_HEADER_BAR_BUTTON_BOX widget but we don't want to draw it. I'm thinking of the best way how to handle it.
(Assignee)

Updated

29 days ago
Duplicate of this bug: 1500847
(Assignee)

Comment 5

28 days ago
Created attachment 9019012 [details]
Bug 1498898 - Don't draw container-only widgets, r=jhorak
(Assignee)

Updated

28 days ago
Assignee: nobody → stransky

Updated

26 days ago
Priority: -- → P1
(Assignee)

Updated

25 days ago
Keywords: checkin-needed

Comment 6

25 days ago
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a63507e990c
Don't draw container-only widgets, r=jhorak
Keywords: checkin-needed

Comment 7

25 days ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0a63507e990c
Status: NEW → RESOLVED
Last Resolved: 25 days ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
status-firefox-esr60: --- → unaffected
(Assignee)

Comment 8

21 days ago
Comment on attachment 9019012 [details]
Bug 1498898 - Don't draw container-only widgets, r=jhorak

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1498356

User impact if declined: Error messages on command line when titlebar is disabled

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Minor code change in theme rendering.

String changes made/needed: none
Attachment #9019012 - Flags: approval-mozilla-beta?
Comment on attachment 9019012 [details]
Bug 1498898 - Don't draw container-only widgets, r=jhorak

[Triage Comment]
Fixes a spurious console warning on Linux. Approved for 64.0b6.
Attachment #9019012 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-

Comment 10

19 days ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/2bb12341b0fd
status-firefox64: affected → fixed
You need to log in before you can comment on or make changes to this bug.