Bugzy's gray bar animation has a white horizontal line when WebRender is enabled

VERIFIED DUPLICATE of bug 1501195

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 1501195
7 months ago
4 months ago

People

(Reporter: cpeterson, Assigned: aosmond)

Tracking

(Blocks 2 bugs, {correctness})

unspecified
Unspecified
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 disabled, firefox62 disabled, firefox63 disabled, firefox64 disabled, firefox65 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 months ago
STR:
1. Enable WebRender
2. Load http://as-bugzy.herokuapp.com/my_bugs
3. Enter your Bugzilla email address

RESULT:
The page's loading animations (the gray vertical bars) have a white horizontal line where the gray vertical bars align. See the attached screenshot.

I am running macOS 10.14 Mojave on a MacBook Pro with a Retina display.

I think this bug is a regression in Firefox 60 Nightly from stacking context bug 1426386. I bisected this bug to the following pushlog:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=de52bf2201a6992df26d0e7c7c1223266bcda4f9&tochange=3dea9196184747f4987cbc95d7d11b8e934a3d11
Priority: -- → P3
This seems fixed. Please reopen if not?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 2

5 months ago
I can still reproduce this bug in 65 Nightly. With WebRender enabled, I see the white lines. With WebRender disabled, I don't see any white lines.

Maybe this is an issue with display scaling? Windows recommends 250% scaling on my laptop (a Razer Blade), but I use 200%. I just tried 250% but I could still see the white lines.
Flags: needinfo?(cpeterson)
I also reproduced the problem on my P50(Win10) with 120%.
Ok, it sounds very snapping related.
Sounds like next step here would be to create a reduced test case.
Posted file Reduced test case
Here's a reduced testcase. Reproduces for me at 120%.

Commenting out the transform:translateZ(0) makes it go away.
Attachment #9034711 - Attachment mime type: text/plain → text/html

This may be the same cause as bug 1501195

Assignee: nobody → aosmond
(Assignee)

Comment 8

4 months ago

Build 20190124104034 and later contains the fix (Windows not out yet but confirmed it is fixed on Linux).

Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1501195
(Reporter)

Comment 9

4 months ago

I have confirmed that this bug is also fixed on Windows.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.