Print Preview allows TAB switching -> invalid behaviour

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: alexander.zink, Assigned: jag-mozilla)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
1. Open the Mozilla Navigator.
2. Open different WWW pages simultaneously into TABs (same Navigator main window).
3. With one of the TABs actiavated, start the Print Preview - the current page
is layed out for printing (page borders are printed).
4. Press the Ctrl-PgUp/Ctrl-PgDn keys to hop between TABs.

The Print Preview GUI remains but the web pages of the other TABs are NOT layed
out for printing but for regular screen display (e.g. the page border is no
longer shown)!

Solutions:
a) Switch to standard GUI for every other TAB but the one(s) the user activated
the Print Preview view for.
b) Disable TAB switching shortcuts while in Print Preview.
c) Allow TAB switching shortcuts, but display all other TAB content correctly as
Print Preview (layed out with page border).

I personally vote for c) -  it's a nice add-on functionality...

Ciao,
Alex

Comment 1

16 years ago
Resolving as a duplicate. If this is not a duplicate, reopen.

See also bug 133503.

*** This bug has been marked as a duplicate of 110641 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
In fact, my solution suggestion a) is basically the same thing that is mentioned 
in bug 110641. 

But this bug report covers the current implementation of the print preview in 
combination with tabbed browsing: the topic of this bug is that tab switching is 
enabled while in print preview, but not working in a reasonable way: If you 
switch to another tab while in print preview, the print preview GUI remains 
while the content of the page (the other tab's content) is displayed as a 
regular web page (not as a print priview!).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
So if this bug is fixed, what will Mozilla's behavior be?
This is basically a regression of bug 127226.
Assignee: rods → jaggernaut
Status: UNCONFIRMED → NEW
Component: Print Preview → Tabbed Browser
Ever confirmed: true
Keywords: regression
OS: Windows 2000 → All
QA Contact: sujay → sairuh
Hardware: PC → All

Comment 5

16 years ago
Fix for b) is available in bug 133503.
QA Contact: sairuh → pmac

Updated

16 years ago
Keywords: mozilla1.3
(Assignee)

Updated

16 years ago
Keywords: nsbeta1

Comment 6

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 7

15 years ago
This bug still exists on Win32 as of build 2003071008.
(Assignee)

Comment 8

15 years ago
The fix for bug 133503 was recently checked in, it should be fixed in today's build.

I think (b) is sufficient to fix this bug. Since there are no visible tabs, I
don't think the user should be able to switch to them. Marking this bug fixed
(by the fix for bug 133503).
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.