Wrap extension name instead of truncating

VERIFIED FIXED in Firefox 64

Status

()

defect
P2
normal
VERIFIED FIXED
6 months ago
6 months ago

People

(Reporter: alice0775, Assigned: mstriemer)

Tracking

64 Branch
mozilla64
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 verified, firefox65 verified)

Details

(Whiteboard: [ux-decision-needed])

Attachments

(4 attachments)

(Reporter)

Description

6 months ago
Posted image screenshot
There is no valid reason to truncate the label.
(Assignee)

Updated

6 months ago
Summary: The label of extension name is too short, and truncated despite having enough blank space → Wrap extension name instead of truncating
(Assignee)

Comment 1

6 months ago
Posted image wrapped.png
I have 17 add-ons and none of them truncate so this seems like a bit of an outlier, however wrapping is probably nicer.

What do you think Emanuela?
Flags: needinfo?(emanuela)
Whiteboard: [ux-decision-needed]
(Assignee)

Comment 2

6 months ago
I discussed this with Emanuela and it would be better if the extension had a shorter name. She's checking with some other UXers if we're better off truncating in hopes of the extension shortening its name or wrapping to make it look a little better with long names.
Priority: -- → P2
(Assignee)

Updated

6 months ago
Assignee: nobody → mstriemer
(Assignee)

Comment 4

6 months ago
Confirmed with Emanuela that wrapping is our best bet here.
Flags: needinfo?(emanuela)
(In reply to Mark Striemer [:mstriemer] from comment #2)
> I discussed this with Emanuela and it would be better if the extension had a
> shorter name. She's checking with some other UXers if we're better off
> truncating in hopes of the extension shortening its name or wrapping to make
> it look a little better with long names.

I'd also like to add that some languages will have longer names due to language constructs. So asking of "shorter names" isn't that friendly.
(Assignee)

Updated

6 months ago
See Also: → 1499666

Comment 6

6 months ago
(In reply to Jared Wein [:jaws] (Regression Engineering Owner for 65) (please needinfo? me) from comment #5)
> (In reply to Mark Striemer [:mstriemer] from comment #2)
> > I discussed this with Emanuela and it would be better if the extension had a
> > shorter name. She's checking with some other UXers if we're better off
> > truncating in hopes of the extension shortening its name or wrapping to make
> > it look a little better with long names.
> 
> I'd also like to add that some languages will have longer names due to
> language constructs. So asking of "shorter names" isn't that friendly.

There is a bigger effort here. We're working on new content guidelines and the extensions and theme manager will change even more in the future... We just needed to figure out what we're doing in this transition time :) 

As someone who doesn't speak English as first language I assure you that I'll be really mindful about other languages limitation.

Comment 7

6 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54315f38f905
Wrap extension name in about:addons r=jaws

Comment 8

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/54315f38f905
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64

Comment 9

6 months ago
Posted image Bug1499109.png
I was able to reproduce this issue on Firefox 62.0.3(20181001155545) under Win 7 64-bit and  Mac OS X 10.13.3.

This issue is verified as fixed on Firefox 65.0a1(20181022220734) and Firefox 64.0b3 (20181022150107) under Win 7 64-bit and Mac OS X 10.13.3.

Please see the attached screenshot.

Updated

6 months ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.