Closed Bug 1499121 Opened 3 years ago Closed 2 years ago

s390x: Firefox 60.2.2 ESR - No graphical elements show when Firefox starts

Categories

(Core :: CSS Parsing and Computation, defect)

60 Branch
Other
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: cgrobertson, Unassigned)

Details

Attachments

(2 files)

Attached image FF60.2.2esr.jpg
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

Steps to reproduce:

Build and run Firefox 60.2.2 ESR on s390x machine.


Actual results:

Firefox comes up but no graphical elements display on the screen. The FF window does not display correctly. I run firefox on command line in a Gnome X11 shell. See attached screen shot of the Firefox window. Here's the console messages when Firefox runs:

~> firefox
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
thread '<unnamed>' panicked at 'internal error: entered unreachable code: Replacing non-declarations style?', servo/components/style/rule_tree/mod.rs:377:26
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Redirecting call to abort() to mozalloc_abort

[Parent 36830, Gecko_IOThread] WARNING: pipe error (49): Connection reset by peer: file /home/abuild/rpmbuild/BUILD/firefox-60.2.2/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 36830, Gecko_IOThread] WARNING: pipe error (38): Connection reset by peer: file /home/abuild/rpmbuild/BUILD/firefox-60.2.2/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 36830, Gecko_IOThread] WARNING: pipe error (37): Connection reset by peer: file /home/abuild/rpmbuild/BUILD/firefox-60.2.2/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353

###!!! [Parent][MessageChannel] Error: (msgtype=0x880001,name=PVsync::Msg_Notify) Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x150080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

~>


Expected results:

Firefox should come up with normal graphical display.
When I build and run Firefox 60.2.0 ESR I see hundreds of these "Crash Annotation GraphicsCriticalError" scroll by on the console. These went away with 60.2.2:

...
Crash Annotation GraphicsCriticalError: |[0][GFX1]: Unknown image format 1 (t=49.181) |[301][GFX1]: Unknown image format 1 (t=66.5122) |[302][GFX1]: Unknown image format 1 (t=66.5122) |[303][GFX1]: Unknown image format 1 (t=66.5123) |[304][GFX1]: Unknown image format 1 (t=66.5123) |[305][GFX1]: Unknown image format 1 (t=66.5123) |[306][GFX1]: Unknown image format 1 (t=66.5124) |[307][GFX1]: Unknown image format 1 (t=66.5291) |[308][GFX1]: Unknown image format 1 (t=66.5292) |[309][GFX1]: Unknown image format 1 (t=85.4107) |[310][GFX1]: Unknown image format 1 (t=85.5733) |[296][GFX1]: Unknown image format 1 (t=66.5109) |[297][GFX1]: Unknown image format 1 (t=66.512) |[298][GFX1]: Unknown image format 1 (t=66.5121) |[299][GFX1]: Unknown image format 1 (t=66.5121) |[300][GFX1]: Unknown image format 1 (t=66.5122) [GFX1]: Unknown image format 1
...
To get to this point with Firefox ESR on s390x we had to patch FF 60.2 with patches from: https://bugzilla.mozilla.org/show_bug.cgi?id=1488552 and https://bugzilla.mozilla.org/show_bug.cgi?id=1472538 (which is slated to be fixed in ESR 60.3). This was to get past the segmentation fault/core dump crashes for big-endian machines.
I'm not sure what is happening in this issue, but I think marking it on component Build Config will be a good starting point so someone will take a look.
Component: Untriaged → Build Config
Product: Firefox → Toolkit
I am seeing this on 60.3.0 on PPC64 as well.  Same exact screenshot, same exact Rust panic.

Should note that Firefox 64 runs beautifully on PPC64 (though the colours are still off in some places), so this is definitely something that *has* been fixed in later versions.  Seems like another backport is in order.

(Also, someone: please change the version on this bug; it's 60 Branch, not 52 Branch.)
Updated to FF 60.3.0 ESR on s390x. Ran FF again on s390x only with `export RUST_BACKTRACE=1` and under gdb (`firefox -d gdb`). Very similar results but after clicking on tabs (opening and closing tabs) a couple of time Firefox crashed in Rust code:

#0  mozalloc_abort (msg=<optimized out>) at /usr/src/debug/firefox-60.3.0/memory/mozalloc/mozalloc_abort.cpp:33
#1  0x000002aa00006c1c in abort () at /usr/src/debug/firefox-60.3.0/memory/mozalloc/mozalloc_abort.cpp:80
#2  0x000003fff80668ac in panic_abort::__rust_start_panic::abort () at libpanic_abort/lib.rs:62
#3  0x000003fff8066894 in __rust_start_panic (_data=0, _vtable=0) at libpanic_abort/lib.rs:57
#4  0x000003fff805707e in std::panicking::rust_panic_with_hook (payload=..., message=..., file_line_col=<optimized out>) at libstd/panicking.rs:433
#5  0x000003fff805911e in std::panicking::begin_panic_fmt (msg=0x3ffffff63a0, file_line_col=0x3fff9537458) at libstd/panicking.rs:349
#6  0x000003fff7f2d242 in style::rule_tree::RuleTree::update_rule_at_level () at servo/components/style/rule_tree/mod.rs:377
Dwarf Error: Cannot find DIE at 0x3198a804 referenced from DIE at 0x3165af8a [in module /usr/lib/debug/usr/lib64/firefox/libxul.so.debug]

The UI was useless again showing nothing except for frame controls like tabs which were responsive until it crashed.

Attached is the complete console output of the debug run including the Rust backtrace and the gdb backtrace.
Firefox 60.3.0 ESR Console output from debug run on s390x machine.
Additional info for comment #5: Clicking the mouse pointer in the URL address field once or twice reliably causes the crash as described. Opening and closing tabs a few times also seems to cause the crash.
Component: Build Config → General: Unsupported Platforms
Product: Toolkit → Firefox Build System
  1. This still affects 60.5.0. I've just tested this today on a PPC64 BE workstation.

  2. This is definitely nothing to do with 'Firefox Build System'; the product assignment is wrong.

  3. It's 60 Branch, not 52 Branch. Charles, as bug opener, you will need to please change the version; with the bug saying 52 Branch, nobody is going to pay attention to it because 52 ESR is (very) closed.

Flags: needinfo?(cgrobertson)
Component: General: Unsupported Platforms → General
Flags: needinfo?(cgrobertson)
OS: Unspecified → Linux
Product: Firefox Build System → Firefox
Hardware: Unspecified → Other
Version: 52 Branch → 60 Branch
Product: Firefox → Core

So, after thinking on it for a while, I think this is (another) bug in Stylo.

The context-click menus are overlaid all over the viewport. That seems like it is not processing the CSS properties of those menus properly.

Combine that with the error in the panic:

thread '<unnamed>' panicked at 'internal error: entered unreachable code: Replacing non-declarations style?', servo/components/style/rule_tree/mod.rs:377:26

Bug 1472538 caused a different crash on BE in Stylo.

That said, I haven't the first clue on how to actually solve this, and we may just want to wait for 68 ESR to come out in July, since central doesn't have anything even approaching this crash. (There are some colour issues on BE, but no crashers that I'm aware of ATM. Still need to spin up a central build newer than December.)

Setting component to CSS parsing. Please re-assign to correct component, if I misunderstood.

Component: General → CSS Parsing and Computation

That panic message sounds extremely weird. But anyhow we're about to ship 68 so this is probably WONTFIX. If the crash or a similar one is still happening, please let me know and I'm happy to help diagnosing / fixing it.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.