Bookmarks disappearing when dragged to themselves

VERIFIED DUPLICATE of bug 143094

Status

Camino Graveyard
General
--
blocker
VERIFIED DUPLICATE of bug 143094
16 years ago
16 years ago

People

(Reporter: Lance Olson, Assigned: Kathleen Brade)

Tracking

({dataloss})

Details

Attachments

(1 attachment, 1 obsolete attachment)

6.62 KB, application/x-macbinary
Details
(Reporter)

Description

16 years ago
Navigator Ver. : 0.3.0 (NB 6/7/02)
OS X Ver. 10.1.5

Bookmarks can be draged, good.  However, if when draging you drop an item (in the 
sidebar) immediately above itself it disappears. The bookmark is in the bookmark menu, 
at the end of the list.  If this bookmark is then selected, Navigator then crashes.  Folders 
can also be dragged into themselves, making all enclosed bookmarks and itself disapear 
from the sidebar, and when selected from the Bookmarks menu, again crashes.  If either 
the bookmark is selected and Nav. Crashes, or if you quit Navigator, all bookmarks that 
have been dragged onto themselves are no longer existant.
(Reporter)

Comment 1

16 years ago
Created attachment 86794 [details]
Crash log for bookmarks

Two crashes in this log, first is after single bookmark click, second is after
bookmark in enclosed folder is clicked.

Comment 2

16 years ago
->pinkerton
Assignee: saari → pinkerton
hewitt
Assignee: pinkerton → hewitt

Comment 4

16 years ago
Nominating as blocker since this is dataloss issue.
Severity: major → blocker

Updated

16 years ago
Summary: Bookmarks dissapearing when draged to themselves → Bookmarks dissapearing when dragged to themselves

Updated

16 years ago
Keywords: dataloss

Updated

16 years ago
Blocks: 147975
(Assignee)

Updated

16 years ago
Summary: Bookmarks dissapearing when dragged to themselves → Bookmarks disappearing when dragged to themselves
(Assignee)

Comment 5

16 years ago
I have a fix for this bug
Assignee: hewitt → brade
(Assignee)

Comment 6

16 years ago
Created attachment 88182 [details] [diff] [review]
fix

reviews?

Updated

16 years ago
Keywords: review
(Assignee)

Updated

16 years ago
Attachment #88182 - Attachment is obsolete: true
(Assignee)

Comment 7

16 years ago
duping to bug 143094 which has a patch that fixes this issue

*** This bug has been marked as a duplicate of 143094 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
yes, that patch does fix both of these issues (i just tested it).

Updated

16 years ago
No longer blocks: 147975

Comment 9

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.