Poor handling of theme in compose window

RESOLVED FIXED in Thunderbird 64.0

Status

defect
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: tim.chambers1968, Assigned: Paenglab)

Tracking

Thunderbird 64.0

Thunderbird Tracking Flags

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

Installed update to version 60.2.1 (64 bit) in linux mint 19 with a dark theme. Run thunderbird. Open compose window.


Actual results:

The new icons and menu text in the main window are clear and neatly overlaid over my theme. In the compose window, the display of the theme image is washed out, making the icons and menu items hard to see (poor contrast).


Expected results:

Compose window should match main window for consistent appearance.

Updated

6 months ago
Component: Untriaged → Theme
(Reporter)

Comment 1

6 months ago
(Reporter)

Comment 2

6 months ago
Further to the initial comment, the format used to display a received email is what I would expect and does not suffer the same issue as the compose window. Example email window screenshot now uploaded
(Assignee)

Comment 3

6 months ago
Posted image mintDark.png
I don't see your issue, see my screenshot. What LW-theme have you applied? Maybe this has a not so good text colour defined.
(Reporter)

Comment 4

6 months ago
OK.

I think the main inbox window looks great and I like the updated icons etc.

I think when opening a received message in its own window, the appearance is consistent with the main inbox window, and that is good.

When I open a compose/write window (as a separate window), the section of the window which has the theme graphic behind it, and includes icons and menus, is much lighter/more greyed out than in either the main or received message windows. Also, in the compose window the light shading appears behind the menu items, but this is not the case in the received message. If the menu text colours are set for a dark theme they become difficult to read in the compose window.

The "mintDark.png" file you uploaded reflects the main window - no issues there. My problem is when I click on the Write icon to compose a new message - the menu items in the pop-up window for that are difficult to read due to the light shading behind them. 

I hope that makes it clearer
(Assignee)

Comment 5

6 months ago
In bug 1486202 I forgot to remove this rules which ends in applying the half transparent background twice.

Bug 1486202 is in ESR, so we need to uplift it.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9017791 - Flags: review?(jorgk)
Attachment #9017791 - Flags: approval-comm-esr60?
Attachment #9017791 - Flags: approval-comm-beta?

Comment 6

6 months ago
Sorry, I see no difference with the patch. I tried with "Thunderbird Suave", but the background image is still too faint in the compose and AB windows. BTW, I'm changing the commit message to:
Bug 1499231 - Bug 1486202 follow-up: Remove rules causing bad LW theme display in compose and AB windows. r=jorgk

Comment 7

6 months ago
Hmm, the image also looks faint in the stand-alone message window, but not quite as faint as in the compose/AB windows.
(Assignee)

Comment 8

6 months ago
You should use a dark LW-theme. Then it's more obvious.

Comment 9

6 months ago
OK, after a chat on IRC I understand that main toolbar and tabbar are themed differently, the toolbar is lighter.

I tried this with a darker LW theme "Dark Fox". In the compose window the disabled Send button is completely invisible now. Otherwise it's an improvement to TB 60.
(Assignee)

Comment 10

6 months ago
(In reply to Jorg K (GMT+2) from comment #9)
> I tried this with a darker LW theme "Dark Fox". In the compose window the
> disabled Send button is completely invisible now.

This is a regression in Daily because of loading toolbarbutton.css as content stylesheet.

Comment 11

6 months ago
Comment on attachment 9017791 [details] [diff] [review]
1499231-lwThemeRules.patch

(In reply to Richard Marti (:Paenglab) from comment #10)
> This is a regression in Daily because of loading toolbarbutton.css as
> content stylesheet.
OK, I take your word for it. Is there a bug for that?

Does the patch apply to beta/ESR?
Attachment #9017791 - Flags: review?(jorgk)
Attachment #9017791 - Flags: review+
Attachment #9017791 - Flags: approval-comm-esr60?
Attachment #9017791 - Flags: approval-comm-esr60+
Attachment #9017791 - Flags: approval-comm-beta?
Attachment #9017791 - Flags: approval-comm-beta+
(Assignee)

Comment 12

6 months ago
I tried it on ESR and it applied.
Keywords: checkin-needed

Comment 13

6 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3b5ab06975e3
Bug 1486202 follow-up: Remove rules causing bad LW theme display in compose and AB windows. r=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

6 months ago
Target Milestone: --- → Thunderbird 64.0
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1500865
You need to log in before you can comment on or make changes to this bug.