Ctrl+arrow to move caret word

VERIFIED DUPLICATE of bug 98546

Status

SeaMonkey
Location Bar
--
enhancement
VERIFIED DUPLICATE of bug 98546
16 years ago
10 years ago

People

(Reporter: Peter Aylett, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Most text editors, including Mozilla (in F7 caret mode) allows a user to move
forward/backward one word at a time by using Ctrl+(right arrow) to advance a
word, and Ctrl+(left arrow) to move back one word. This feature is not available
in the URL bar.

This feature is supported in Internet Explorer. While it would not used often by
users, it is very handy for web-developers who would be manually modifying their
URLs by hand fairly frequently.

(Not important - just a wish)

Actual Results:  Ctrl+(left or right arrow) currently jumps to the start/end of
the URL, the same as 'Home' and 'End'.

Expected Results:  Ctrl+(left arrow) would move the caret one word (section of
domain name, or folder, etc) to the left, and Ctrl+(right arrow) would move the
caret one word to the right.

Comment 1

16 years ago
Confirmed, Agreed.
It's not a good idea to have two buttons for same functions (End/Cttrl-right,
Home/Ctrl-left) when another useful function is missing.

Sorry, cant vote for this bug right now, but as soon as something on my vote
list gets fixed, I'll add my freed vote here. ;)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 98546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.