Icons cannot be placed next to menu any more.

RESOLVED FIXED in Thunderbird 64.0

Status

defect
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: thomas.hebinck, Assigned: Paenglab)

Tracking

Thunderbird 64.0

Thunderbird Tracking Flags

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

I try to have the icons next to the menu (File, Edit, ... [Send], [Save]). (via customize toolbars)


Actual results:

This doesn't work any more in Compose- and Read-windows. It only works in the main window.


Expected results:

Icons should be placed next to the menu everywhere, like it was always.
Exact version is 60.2.1 (64-bit) on Ubuntu
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
We need that our binding is used and not the one from m-c. I haven't seen a menubar which isn't inside a toolbox, so this should be safe.
Attachment #9017893 - Flags: review?(acelists)
Comment on attachment 9017893 [details] [diff] [review]
1499435-menubar.patch

Review of attachment 9017893 [details] [diff] [review]:
-----------------------------------------------------------------

So this increases specificity so that our binding is chosen?
Can't we use a different name for the binding to avoid clashes? We should do something similar in the textbox case. Yeah, that would hit addons, so probably not doable... :(
(In reply to :aceman from comment #2)
> Comment on attachment 9017893 [details] [diff] [review]
> 1499435-menubar.patch
> 
> Review of attachment 9017893 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> So this increases specificity so that our binding is chosen?

Yes.

> Can't we use a different name for the binding to avoid clashes? We should do
> something similar in the textbox case. Yeah, that would hit addons, so
> probably not doable... :(

The binding itself would be no problem. But the specificity wouldn't change. Renaming the toolbar could work but this would end in renaming this in many XUL files and we still use toolkit binding which would also needed to be adapted in some way.
Comment on attachment 9017893 [details] [diff] [review]
1499435-menubar.patch

Review of attachment 9017893 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, works for me.
Attachment #9017893 - Flags: review?(acelists) → review+
Keywords: checkin-needed
Comment on attachment 9017893 [details] [diff] [review]
1499435-menubar.patch

[Approval Request Comment]

Without the patch, dragging items from the customize palette to a place next to the menu produces:
TypeError: toolbar.insertItem is not a function, customizeToolbar.js:746
Attachment #9017893 - Flags: approval-comm-esr60?
Attachment #9017893 - Flags: approval-comm-beta?
Attachment #9017893 - Flags: approval-comm-esr60?
Attachment #9017893 - Flags: approval-comm-esr60+
Attachment #9017893 - Flags: approval-comm-beta?
Attachment #9017893 - Flags: approval-comm-beta+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ba6de8f2e729
Fix customization of menubar. r=aceman
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Please add some meaningful commit messages. I moved the
  Use our toolbar[type="menubar"]:not([autohide="true"]) and not the toolkit one.
below as a comment.
Target Milestone: --- → Thunderbird 64.0
You need to log in before you can comment on or make changes to this bug.