Closed Bug 1499457 Opened 11 months ago Closed 11 months ago

TPS virtual env fails to install

Categories

(Firefox :: Sync, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: tcsc, Unassigned)

References

Details

Trying to install the TPS changes from bug 1488899, I get

error: mozfile 2.0.0 is installed but mozfile==1.* is required by set(['mozrunner', 'mozprofile'])
Traceback (most recent call last):
  File "./create_venv.py", line 199, in <module>
    main()
  File "./create_venv.py", line 164, in main
    os.path.join(here, 'setup.py'), 'install'])
  File "/usr/local/Cellar/python@2/2.7.15_1/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 190, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/Users/thom/.tps/venv/bin/python', '/Users/thom/gecko/testing/tps/setup.py', 'install']' returned non-zero exit status 1

Pinning the `mozfile` version as 'mozfile == 1.2' seems to work, and might be the right choice? I don't know.

Anyway, this is probably why we haven't seen a "TPS Prod Failed!" email since Oct 11. (And thus, it's unrelated to bug 1488899... probably)

See also bug 1492341 which is the same kind of thing, e.g. some dependency we have in TPS is busted on pypi. (It might be worth figuring out how hard it is to use the local versions of the dependencies?).
I saw this on my Linux box before bug 1488899. Strangely I didn't see it on Windows. I also note that mozfile 2.0 was released only days ago. Regardless, on my Linux box I worked around it by executing:

% pip uninstall mozfile
% pip install "mozfile==1.*"
% pip install "mozdevice==1.*"

and it worked ok.
mozfile 2.0.0 was released as part of bug 1471622, where we also updated the version specifier for the TPS virtual environment to >=1.2. The version dependencies of mozrunner and mozprofile were also updated at this time, however we'll need new releases of both of these packages for the all of the dependencies to be satisfied by what's available on PyPI. Whilst pinning mozfile to 1.2 in the TPS environment would work, this will make it harder when we shift to using the local versions for TPS as the versions will no longer match.
Dave, can this be closed?
Flags: needinfo?(dave.hunt)
Yes, thanks for the reminder!
Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(dave.hunt)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.