Closed Bug 1499472 Opened Last year Closed Last year

History search field in SeaMonkey 2.49.4 missing under macOS

Categories

(SeaMonkey :: Bookmarks & History, defect)

SeaMonkey 2.49 Branch
All
macOS
defect
Not set

Tracking

(seamonkey2.49esr fixed, seamonkey2.53 unaffected)

RESOLVED FIXED
seamonkey2.49
Tracking Status
seamonkey2.49esr --- fixed
seamonkey2.53 --- unaffected

People

(Reporter: frg, Assigned: frg)

References

Details

(Keywords: regression)

Attachments

(2 files)

Unfortunately Bug 1457312 caused a regression on macOS where the search box now is no longer shown.

http://forums.mozillazine.org/viewtopic.php?f=5&t=3042383

+++ This bug was initially created as a clone of Bug #1457312 +++

Fixed for 2.53 and up in Bug 1378089 by showing a unified view. This is 2.49 only at this point in time.

Search in bookmarks is shown in the menu in the bookmarks manager and on a separate toolbar in the history page.
This works fine with just type="menubar" under Windows but not under macOS. Using the same attributes as the bookmarks menu/toolbar seems to work ok here. Tested under Windows and macOS 10.14.

This is for 2.49 comm-esr52 only. 2.53 and up use the ported library.
Attachment #9017637 - Flags: review?(stefanh)
Summary: The bookmarks and history search fields are inconsistent with each other. → History search field in SeaMonkey 2.49.4 missing under macOS
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
I don't have a 2.49 tree handy atm, can you post a screenshot? The window should be unified and the search field should really be at the right (but it's at the left in 2.49.1, so I guess we could live with it being at the left...).
Flags: needinfo?(frgrahl)
btw - the reason the toolbar vanished is because of this: https://dxr.mozilla.org/mozilla-esr52/rev/5350524bb6543084fbba8604ce050794d0bc70ae/toolkit/content/xul.css#291 (instead widget code puts the menubar at the top of the screen).
Bookmarks and History now look exactly the same. The search field is on the right in a separate bar in the Window. Only in Windows both are at the right of the menubar.
Flags: needinfo?(frgrahl)
The test build I baked yesterday is now on Bills page: 
http://www.wg9s.com/comm-esr/
Comment on attachment 9017637 [details] [diff] [review]
1499472-history.patch

Nice, thanks.
Attachment #9017637 - Flags: review?(stefanh) → review+
Attachment #9017637 - Flags: approval-comm-esr52?
Comment on attachment 9017637 [details] [diff] [review]
1499472-history.patch

a=me
Attachment #9017637 - Flags: approval-comm-esr52? → approval-comm-esr52+
Target 2.49.5 comm-esr52 only patch
https://hg.mozilla.org/releases/comm-esr52/rev/76b95caa256af24d798f862065da2f89c23c6f40
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.49

Hi,

I'm surprised to see this listed as fixed: I was not having this problem on whatever build I was using before, but just upgraded to 2.49 last night, and NOW I have this problem! Search in bookmarks still works fine, and yes I found the sidebar hack on the SM forums, but there is no search field in the shift-command-H history which is what I've always used in the past.

I'm surprised to see this listed as fixed:

It is fixed for 2.49.5. We are still having fun building it.

If you want you can try the unofficial build:

http://www.wg9s.com/comm-esr/

You need to log in before you can comment on or make changes to this bug.