Closed Bug 1499485 Opened Last year Closed 4 months ago

Intermittent [TVw] /webdriver/tests/element_clear/clear.py | test_resettable_element_does_not_satisfy_validation_constraints[week-foo] - teardown error

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(firefox64 fixed)

RESOLVED FIXED
Tracking Status
firefox64 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ato)

References

Details

(Keywords: intermittent-failure)

Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=205899442&repo=autoland

https://queue.taskcluster.net/v1/task/Hb6WbrblSoO3ZdwscVu42Q/runs/0/artifacts/public/logs/live_backing.log

19:02:40     INFO - TEST-PASS | /webdriver/tests/element_clear/clear.py | test_resettable_element_does_not_satisfy_validation_constraints[week-foo] 
19:02:40     INFO - TEST-UNEXPECTED-ERROR | /webdriver/tests/element_clear/clear.py | test_resettable_element_does_not_satisfy_validation_constraints[week-foo] - teardown error
19:02:40     INFO - capabilities = {}
19:02:40     INFO - configuration = {'capabilities': {'moz:firefoxOptions': {'binary': 'Z:\task_1539714711\build\application\firefox\firefox.exe', 'prefs'...b-platform.test,www.web-platform.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test'}}}, 'host': '127.0.0.1', 'port': 4444}
19:02:40     INFO - request = <SubRequest 'session' for <Function 'test_resettable_element_does_not_satisfy_validation_constraints[week-foo]'>>
19:02:40     INFO - 
19:02:40     INFO -     @pytest.fixture(scope="function")
19:02:40     INFO -     def session(capabilities, configuration, request):
19:02:40     INFO -         """Create and start a session for a test that does not itself test session creation.
19:02:40     INFO -     
19:02:40     INFO -         By default the session will stay open after each test, but we always try to start a
19:02:40     INFO -         new one and assume that if that fails there is already a valid session. This makes it
19:02:40     INFO -         possible to recover from some errors that might leave the session in a bad state, but
19:02:40     INFO -         does not demand that we start a new session per test."""
19:02:40     INFO -         global _current_session
19:02:40     INFO -     
19:02:40     INFO -         # Update configuration capabilities with custom ones from the
19:02:40     INFO -         # capabilities fixture, which can be set by tests
19:02:40     INFO -         caps = copy.deepcopy(configuration["capabilities"])
19:02:40     INFO -         caps.update(capabilities)
19:02:40     INFO -         caps = {"alwaysMatch": caps}
19:02:40     INFO -     
19:02:40     INFO -         # If there is a session with different capabilities active, end it now
19:02:40     INFO -         if _current_session is not None and (
19:02:40     INFO -                 caps != _current_session.requested_capabilities):
19:02:40     INFO -             _current_session.end()
19:02:40     INFO -             _current_session = None
19:02:40     INFO -     
19:02:40     INFO -         if _current_session is None:
19:02:40     INFO -             _current_session = webdriver.Session(
19:02:40     INFO -                 configuration["host"],
19:02:40     INFO -                 configuration["port"],
19:02:40     INFO -                 capabilities=caps)
19:02:40     INFO -         try:
19:02:40     INFO -             _current_session.start()
19:02:40     INFO -         except webdriver.error.SessionNotCreatedException:
19:02:40     INFO -             if not _current_session.session_id:
19:02:40     INFO -                 raise
19:02:40     INFO -     
19:02:40     INFO -         # Enforce a fixed default window size
19:02:40     INFO -         _current_session.window.size = defaults.WINDOW_SIZE
19:02:40     INFO -     
19:02:40     INFO -         yield _current_session
19:02:40     INFO -     
19:02:40     INFO - >       cleanup_session(_current_session)
19:02:40     INFO - 
19:02:40     INFO - capabilities = {}
19:02:40     INFO - caps       = {'alwaysMatch': {'moz:firefoxOptions': {'binary': 'Z:\task_1539714711\build\application\firefox\firefox.exe', 'prefs':...w1.not-web-platform.test,www.not-web-platform.test,www.web-platform.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test'}}}}
19:02:40     INFO - configuration = {'capabilities': {'moz:firefoxOptions': {'binary': 'Z:\task_1539714711\build\application\firefox\firefox.exe', 'prefs'...b-platform.test,www.web-platform.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test'}}}, 'host': '127.0.0.1', 'port': 4444}
19:02:40     INFO - request    = <SubRequest 'session' for <Function 'test_resettable_element_does_not_satisfy_validation_constraints[week-foo]'>>
19:02:40     INFO - 
19:02:40     INFO - tests\web-platform\tests\webdriver\tests\conftest.py:160: 
19:02:40     INFO - _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
I wonder if that is a regression from bug 1499135, and if yes bug 1499057 (with the real fix) with the backout of the patch from bug 1499135 might make it disappear.
Yeah, that could very well be the cause of regression. Even though it shouldn't. There is something rather weird happening with webdriver - though I obviously am not familiar with its code, so I could be making wrong assumptions how things work.

Most likely fixed by Andreas' patch on bug 1499057.

Assignee: nobody → ato
No longer blocks: 1499057, 1499135
Status: NEW → RESOLVED
Closed: 4 months ago
Depends on: 1499057
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.