Update triage owner list to include all Firefox-related major products and stop saying __Any__

RESOLVED FIXED

Status

()

task
RESOLVED FIXED
7 months ago
a month ago

People

(Reporter: calixte, Assigned: kohei)

Tracking

({ux-mode-error})

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
When selecting "Product: __Any__" and "generate report", sledru@mozilla.com doesn't appear in the list.
And when selecting "Product: Firefox Build System", it appears.
Assignee: administration → nobody
Component: Administration → Extensions: BMO
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
Only 5 products are displayed when no products are selected, and it’s apparently “by design” as per Bug 1309965. I’d agree that the UI is confusing.

https://github.com/mozilla-bteam/bmo/blob/master/extensions/BMO/lib/Reports/Triage.pm#L28-L34
Keywords: ux-mode-error
(Reporter)

Comment 2

7 months ago
__Any__ should mean any so it's a bug by design.
This report needs to be updated as the product hierarchy in BMO has changed since it was first built.
Kohei, could you please take care of that?
I would like to see these products:

            "Core",
            "DevTools",
            "Firefox",
            "Firefox for Android",
            "Firefox Build System",
            "Testing",
            "Toolkit",
            "WebExtensions"

AFAIK, they are the fx components.
Flags: needinfo?(kohei.yoshino)
Okay, will update the default and change “__Any__” to “All Firefox components” maybe?
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Flags: needinfo?(kohei.yoshino)
Sounds good.
please also add "External Software Affecting Firefox" to the list
I’ve double checked the UI and think “Firefox-related major products” might be a better fit, because Firefox for iOS, Echo Show, FireTV are not included, and the dropdown is not for Component but for Product.

(In reply to Sylvestre Ledru [:sylvestre] from comment #6)
> please also add "External Software Affecting Firefox" to the list

Got it!
Summary: The triage owner list in https://bugzilla.mozilla.org/page.cgi?id=triage_owners.html&product=&owner= is partial → Update triage owner list to include all Firefox-related major products and stop saying __Any__
Merged to master.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Type: defect → task
You need to log in before you can comment on or make changes to this bug.