Talos pageloader intermittently fails to load pages locally

RESOLVED FIXED in Firefox 64

Status

defect
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: miko, Assigned: rwood)

Tracking

Trunk
mozilla64
Points:
---

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

7 months ago
Running |mach talos-test -a displaylist_mutate| locally fails intermittently (almost every second or so run) on macOS. This seem to happen most often when the test URL changes. The frequency seems to be dependent on CPU load and focus: more load/no focus -> less frequent failures.

The browser shows:
"
Unable to connect

Firefox can’t establish a connection to the server at localhost:57344.
"

Refreshing the page with a keyboard shortcut successfully loads the page. The URL shown in the console works when opening on another browser.
I have ran this test a good bit in the last month locally and it works well on windows 10, I know :rwood has osx, maybe he can do 10 runs in a row and see if he can repo/fix this.
Flags: needinfo?(rwood)
Assignee

Comment 2

7 months ago
Thanks :miko, I am able to reproduce this on my MacBook Pro with latest inbound with the talos test noted above. I'll try to look into this...

I've been seeing similar localhost issues with raptor tp6 (where the mitmproxy webserver seems to stall on my localhost). I had assumed it was a weird issue with my own machine's localhost or something. Not sure if that is related though.
Flags: needinfo?(rwood)
Assignee

Comment 3

7 months ago
I saw some issues on the web concerning 'localhost' resolving slower on macOS High Sierra, vs using '127.0.0.1'.

I changed talos locally to use '127.0.0.1' instead of 'localhost' here [1] and now I can't seem to repro the issue - I ran |mach talos-test -a displaylist_mutate| locally successfully 7x in a row then stopped trying. I'm not sure if it's just a total co-incidence though or if using the IP instead is actually significant.

:miko, are you on High Sierra also? Can you please try the same local talos change and try it again and see if that makes any difference on your machine? Thanks!

[1] https://searchfox.org/mozilla-central/rev/eef79962ba73f7759fd74da658f6e5ceae0fc730/testing/talos/talos/config.py#140
Flags: needinfo?(mikokm)
Reporter

Comment 4

7 months ago
(In reply to Robert Wood [:rwood] from comment #3)
> I saw some issues on the web concerning 'localhost' resolving slower on
> macOS High Sierra, vs using '127.0.0.1'.
> 
> I changed talos locally to use '127.0.0.1' instead of 'localhost' here [1]
> and now I can't seem to repro the issue - I ran |mach talos-test -a
> displaylist_mutate| locally successfully 7x in a row then stopped trying.
> I'm not sure if it's just a total co-incidence though or if using the IP
> instead is actually significant.
> 
> :miko, are you on High Sierra also? Can you please try the same local talos
> change and try it again and see if that makes any difference on your
> machine? Thanks!
> 
> [1]
> https://searchfox.org/mozilla-central/rev/
> eef79962ba73f7759fd74da658f6e5ceae0fc730/testing/talos/talos/config.py#140

This sounds like a reasonable analysis, especially since the problem seems timing related. I tried changing the URL from localhost to 127.0.0.1, and did not experience a single failure in 5 runs or so.

My MBP is running Mojave.
Flags: needinfo?(mikokm)
Summary: Talos pageloader locally at least with displaylist_mutate → Talos pageloader intermittently fails to load pages locally
Assignee

Comment 5

7 months ago
That's good news thanks :miko. I will make a patch to change talos to use the IP.
Assignee: nobody → rwood
Status: NEW → ASSIGNED
Assignee

Updated

7 months ago
See Also: → 1500236

Comment 8

7 months ago
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87c2fcb3b614
Talos pageloader intermittently fails to load pages locally; r=jmaher

Comment 9

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/87c2fcb3b614
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.