Closed Bug 1499746 Opened Last year Closed Last year

[Nightly] asm.js issue *may* be causing issues working with AWS Lambda

Categories

(Core :: DOM: Core & HTML, defect)

64 Branch
Desktop
Unspecified
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1496754
Tracking Status
firefox64 --- affected

People

(Reporter: subbaraman.kiran, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

I initially reported this issue here: https://stackoverflow.com/questions/52830727/aws-lambda-calling-the-invoke-api-action-failed-with-this-message-object-obje


* When I try to invoke my AWS Lambda function, by clicking on "Test" button, I see the an error reported on the AWS screen - basically it is unable to invoke the function.
* Issue seen on browser: Firefox Nightly 64.0a1 (2018-10-17) (64-bit), on a Windows 10 system.



Actual results:

In the dev-tools console, I see this error: TypeError: asm.js type error: Disabled by 'asmjs' runtime option   rusha.min.js
* In the Network tab, of the Firefox dev-tools, I see that the invocation returns with a 403 error. The response is : {"message":"The request signature we calculated does not match the signature you provided. Check your AWS Secret Access Key and signing method. Consult the service documentation for details."}


Expected results:

The AWS Lambda function should have gotten invoked, when I click on the "Test" button.
This works as expected on Microsoft Edge, and Chrome browsers.

I have not tried to make this work on the "regular" Firefox release. Will report back, when I do.
Just tried this on Firefox Quantum 62.0.3, on Windows 10, and it works as expected.
I can reproduce the problem on 64.0a1 (2018-10-17) (64-bit) on OS X. When I click test there is a 403 response on invocations with the error message Kiran mentioned.
I get a 403 error with the same message about the request signature if I try to create a new lambda function, so this is likely a duplicate of bug 1495770.
We can not confirm this issue since it needs an AWS Lambda account. Brian Pitts has confirmed it tho.
I will set the bug's component as (Core) DOM, like the issue related to this one, bug 1496754.
Component: Untriaged → DOM
Product: Firefox → Core
Hardware: Unspecified → Desktop
See Also: → 1496754
Just wanted to report that I do not see this issue in the "65.0a1 (2018-10-22) (64-bit)" build. It's working as expected.
I can also confirm this is working now on 65.0a1. I'll go ahead and close this as a duplicate of the bug danibodea mentioned.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1496754
Thanks for your support
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.