If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Load MailNews in browser window creates endless sort loop

RESOLVED WONTFIX

Status

SeaMonkey
MailNews: Message Display
--
trivial
RESOLVED WONTFIX
16 years ago
11 years ago

People

(Reporter: riscky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build: 2002060708
Mac OS X: 10.1.5
Marked: Trivial due to lack of use

If one enters chrome://messenger/content/messenger.xul as a url in the URLBar
and presses return Mail & News launches. However, the listed accounts endlessly
resort them self’s.

Reproducible always.

What should happen is that Main and News should load in the browser window… or
open a new Mail & News window if it is not desirable to load Main & News in a
browser window.

Comment 1

16 years ago
To my knowledge, that is not a supported method of launching MailNews. What's the bug here?
Summary: Load Mail & News in browser window creaates endless sort loop → Load MailNews in browser window creates endless sort loop
(Reporter)

Comment 2

16 years ago
If it is not supported the user should not be allowed to do this... at least not
with out some form of warning. Even if it is not a supported method, it is a
bug. Allowing a user to do something that is not supported, which could lead to
a crash or an unstable situation in my book is a bug. 

Supported or not it does not do what is expected… work or disallow the event for
occurring. Maybe the severity at the very least the severity should be changed
from trivial to enhancement.  Something needs to be done.

Sites like xulplanet.com use mail and news as an example of how the call chrome
files (http://www.xulplanet.com/tutorials/xultu/chromeurl.html)

Comment 3

16 years ago
*** Bug 151526 has been marked as a duplicate of this bug. ***

Updated

16 years ago
OS: MacOS X → All
Hardware: Macintosh → All

Comment 4

16 years ago
Supported or not, for me this functionality has been a great way to use Mozilla.
I keep Mozilla open all the time, I constantly have the Messenger open in the
first tab, and I do surfing in other tabs. Mail notification is not good enough,
Messenger window is slow to open, and yet too large to keep it open as yet
another window. I'm going back to 1.0 until this bug is fixed.

Updated

15 years ago
QA Contact: olgam → laurel

Comment 5

15 years ago
W2KSP3 Mozilla 1.3b 2003021008

You should change this from 'Unconfirmed"
And don't dismiss this feature as unsupported,
while Mozilla is instructing on it in the FAQ.
As long as people are being lured into using it, it is not "Trivial."
I tried this only because it is mentioned at
http://www.mozilla.org/start/1.0/faq/mail-news.html#3.4

> 3.4. Can I open Mail/News in a tab in the browser?
> 
>   Enter chrome://messenger/contents/messenger.xul in the address bar of a tab.
You can bookmark this tab, including as part of a group bookmark.
> 
>   Note: This is unsupported. Odd things may happen, e.g., all of Mozilla
closing when you close the tab.

I've just had some Windows malfunction and have a clean installation of W2k.
Trying to setup Mozilla again, which is always difficult. :)
So I don't yet have an email account setup, and was looking (again) for a clue
about how to designate where my profile is already stored. So, having no profile
at all, I did not get behavior recognizable as the loop described in initial
report of the bug, but was prompted to set up a profile, and then the hourglass
throbbed and the system became unresponsive. No problem killing it with TaskManager.
Product: Browser → Seamonkey

Comment 6

13 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Assignee: sspitzer → mail
wontfix per developer CTho. This will not be supported.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.