Closed Bug 1499896 Opened Last year Closed Last year

ActorManagerChild.jsm, line 190: TypeError: this.listeners is null

Categories

(Toolkit :: Async Tooling, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 + fixed
firefox64 + fixed
firefox65 + fixed

People

(Reporter: Felipe, Assigned: Felipe)

References

Details

(Keywords: regression)

Attachments

(1 file)

Not sure how this didn't show up before, but a pagehide followed by a pageshow (triggered a cleanup and reinit) of the SingletonDispatcher makes later attempts to re-add listeners fail because it's no longer an array
This totally breaks scripting Firefox 63, e.g. with slimer.js (https://github.com/laurentj/slimerjs/issues/708). Is there any way to push it to the next point release? The fix is correct (and no-risk).
[Tracking Requested - why for this release]:
As mentioned in comment 2, this breaks scripting with slimer.js, and the github issue says it's not possible to work around on their end.

It would be awesome to include this fix in a 63 dot release
Felipe, could you land and request uplift to beta and release? Thanks
Flags: needinfo?(felipc)
Keywords: regression
Pushed by fgomes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/432f44b8e53e
Clean up listeners to an empty array instead of null. r=mconley
Comment on attachment 9018083 [details]
Bug 1499896 - Clean up listeners to an empty array instead of null. r=kmag

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1472491

User impact if declined: This exception thrown breaks slimer.js for Firefox 63

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: The fix has been verified by the reporter mentioning the slimer.js problem

List of other uplifts needed: none

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Simple one liner to make the code correct

String changes made/needed: none
Flags: needinfo?(felipc)
Attachment #9018083 - Flags: approval-mozilla-release?
Attachment #9018083 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/432f44b8e53e
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Is is possible to create a test for this?
Flags: qe-verify+
Flags: needinfo?(felipc)
Flags: in-testsuite?
Comment on attachment 9018083 [details]
Bug 1499896 - Clean up listeners to an empty array instead of null. r=kmag

[Triage Comment]
Fixes an exception which breaks slimer.js. Approved for 64.0b6.
Attachment #9018083 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> Is is possible to create a test for this?

Yeah probably. I split that to bug 1503667
Flags: needinfo?(felipc)
AIUI, the requirements to verify this issue would be to get slimer.js and run a script that contains page.viewportSize = { width : width, height : height }; 

The slimer.js 1.0.0 is compatible with firefox v < 59 and I'm not sure how to build the branch: https://github.com/MarkR42/slimerjs/tree/firefox63 .

Could someone provide additional information/STR to aid in this issue's verification?
Flags: needinfo?(ryanvm)
Flags: needinfo?(felipc)
(In reply to Adrian Florinescu [:adrian_sv] from comment #12)
> AIUI, the requirements to verify this issue would be to get slimer.js and
> run a script that contains page.viewportSize = { width : width, height :
> height }; 

Since a release version of slimer.js that is compatible with Firefox 63 hasn't been released yet, and the reporter on comment 2 confirmed that the fix works, I don't think it's necessary for us to verify it.
Flags: needinfo?(ryanvm)
Flags: needinfo?(felipc)
Thanks Felipe, SGTM. Based on comment 13, removing the qe+ flag.
Flags: qe-verify+
Blocks: 1506678
Duplicate of this bug: 1506678
Comment on attachment 9018083 [details]
Bug 1499896 - Clean up listeners to an empty array instead of null. r=kmag

Trivial patch, already on beta with no reported regression, approved for our next dot release, thanks.
Attachment #9018083 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.