Closed Bug 1499937 Opened 3 years ago Closed 1 year ago

Issue 1366060 "Tab moving/reordering animations should be disabled if toolkit.cosmeticAnimations.enabled=false" broken in 62.0.3

Categories

(Firefox :: Tabbed Browser, defect, P5)

62 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: charles.belov, Unassigned)

References

Details

(Keywords: regression, regressionwindow-wanted)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

1. Launch Firefox with 30+ home page tabs 
2. Set toolkit.cosmeticAnimations.enabled=false
3. Quit and re-launch Firefox
4. Click > or < icon next to viewable tabs
5. Choose history menu item


Actual results:

4. Tabs animate in direction of arrow



Expected results:

4. Tabs redraw to direction of arrow without animating.
Sorry, please ignore step 5; it's a separate but related issue.
This issue seems to already be in Bugzilla so I'm going to mark it as Resolved-Duplicate.
Thanks for reporting!
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380065
This isn't the right dupe. Each animation needs to be explicitly written to observe the pref, so the fact that one feature works doesnt mean they all do and vice-versa. I have a feeling there is a dupe for this particular issue, but I can't find it. Moving component so we can triage it there.
Status: RESOLVED → REOPENED
Component: Untriaged → General
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Component: General → Tabbed Browser
Priority: -- → P5
Status: NEW → RESOLVED
Closed: 3 years ago1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.