Closed Bug 1499951 Opened 1 year ago Closed 1 year ago

Green up wpt fetch directory on fennec

Categories

(Testing :: web-platform-tests, defect)

Version 3
defect
Not set

Tracking

(firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: KWierso, Assigned: jgraham)

References

Details

Attachments

(1 file, 2 obsolete files)

Nice mix of FAILs, UNEXPECTED PASSes, and TIMEOUTs.


Unexpected Results
------------------
/fetch/api/cors/cors-preflight-referrer.any.html
  FAIL Referrer policy: "" and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.html" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: "" and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/myreferrer" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin-when-cross-origin and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin-when-cross-origin and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: unsafe-url and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.html" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: unsafe-url and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/myreferrer" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9

/fetch/api/cors/cors-preflight-referrer.any.worker.html
  FAIL Referrer policy: "" and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.worker.js" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: "" and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/myreferrer" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin-when-cross-origin and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: origin-when-cross-origin and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: unsafe-url and referrer: default - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.worker.js" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9
  FAIL Referrer policy: unsafe-url and referrer: 'myreferrer' - assert_equals: Preflight's referrer is correct expected "http://web-platform.test:8000/fetch/api/cors/myreferrer" but got ""
corsPreflightReferrer/</</<@http://web-platform.test:8000/fetch/api/cors/cors-preflight-referrer.any.js:24:9

/fetch/api/redirect/redirect-location.any.html
  UNEXPECTED-PASS Redirect 301 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 302 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 303 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 307 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 308 in "manual" mode with invalid location

/fetch/api/redirect/redirect-location.any.worker.html
  UNEXPECTED-PASS Redirect 301 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 302 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 303 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 307 in "manual" mode with invalid location
  UNEXPECTED-PASS Redirect 308 in "manual" mode with invalid location

/fetch/api/request/destination/fetch-destination.https.html
  TIMEOUT /fetch/api/request/destination/fetch-destination.https.html

/fetch/api/response/response-static-redirect.html
  FAIL Check default redirect response - assert_equals: expected "" but got "OK"
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:23:9
Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1561:20
test@http://web-platform.test:8000/resources/testharness.js:544:21
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:15:7
  FAIL Check response returned by static method redirect(), status = 301 - assert_equals: expected "" but got "OK"
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:34:11
Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1561:20
test@http://web-platform.test:8000/resources/testharness.js:544:21
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:27:9
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:26:33
  FAIL Check response returned by static method redirect(), status = 302 - assert_equals: expected "" but got "OK"
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:34:11
Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1561:20
test@http://web-platform.test:8000/resources/testharness.js:544:21
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:27:9
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:26:33
  FAIL Check response returned by static method redirect(), status = 303 - assert_equals: expected "" but got "OK"
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:34:11
Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1561:20
test@http://web-platform.test:8000/resources/testharness.js:544:21
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:27:9
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:26:33
  FAIL Check response returned by static method redirect(), status = 307 - assert_equals: expected "" but got "OK"
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:34:11
Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1561:20
test@http://web-platform.test:8000/resources/testharness.js:544:21
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:27:9
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:26:33
  FAIL Check response returned by static method redirect(), status = 308 - assert_equals: expected "" but got "OK"
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:34:11
Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1561:20
test@http://web-platform.test:8000/resources/testharness.js:544:21
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:27:9
@http://web-platform.test:8000/fetch/api/response/response-static-redirect.html:26:33

/fetch/security/embedded-credentials.tentative.sub.html
  TIMEOUT /fetch/security/embedded-credentials.tentative.sub.html
Attached image Dialog that's held open
This dialog pops up during the test on Fennec and is not clicked through. I think this is causing the timeouts to occur, and may be the cause of all of the issues. Should we just annotate this as failing on Fennec?
Flags: needinfo?(james)
I'm not sure why this should be different on Android, but it seems like setting the pref network.http.phishy-userpass-length to something longer than the combined username + password should prevent this dialog appearing (geckodriver seems to set it to 255 by default, something similarly large is probably fine here).
Flags: needinfo?(james)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca404730fbbb
Disable phishing prompt in wpt tests, r=ato
https://hg.mozilla.org/mozilla-central/rev/ca404730fbbb
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Attachment #9023197 - Attachment is obsolete: true
Attachment #9022553 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.