All users were logged out of Bugzilla on October 13th, 2018

warning fix : ns/nsprpub/pr/src/threads/combined/pruthr.c

VERIFIED FIXED

Status

P3
trivial
VERIFIED FIXED
21 years ago
4 years ago

People

(Reporter: rick, Assigned: wtc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

21 years ago
Created by Rick Osborne (rick@rixsoft.com) on Saturday, April 11, 1998 10:36:56 PM PDT
Additional Details :
(In the continuing quest to eliminate even compiler warnings
... )

Ever more compiler directives mucking with variable scopes.

--- pruthr.c	Sun Apr 12 01:39:09 1998
+++ pruthr.old.c	Wed Apr 08 17:55:09 1998
@@ -440,5 +440,3 @@ void _PR_UserRunThread(void)
     PRThread *thread = _PR_MD_CURRENT_THREAD();
-#ifndef _PR_GLOBAL_THREADS_ONLY /* calls to var get thrown
out */
     PRIntn is;
-#endif

@@ -522,5 +520,3 @@ void _PR_UserRunThread(void)
         {
-#ifndef _PR_GLOBAL_THREADS_ONLY /* calls to var get thrown
out */
             PRInt32 is;
-#endif
             _PR_INTSOFF(is);
@@ -536,8 +532,3 @@ void _PR_SetThreadPriority(PRThread *thr
     PRThread *me = _PR_MD_CURRENT_THREAD();
-#ifndef _PR_GLOBAL_THREADS_ONLY
-    /* since this is all macro''ed, we get a warning in the
-       above case due to the compiler throwing out the call
-       and thinking the var goes unreferenced */
     PRIntn is;
-#endif

@@ -605,5 +596,3 @@ static void _PR_Suspend(PRThread *thread
 {
-#ifndef _PR_GLOBAL_THREADS_ONLY
     PRIntn is;
-#endif
     PRThread *me = _PR_MD_CURRENT_THREAD();
@@ -663,5 +652,3 @@ static void _PR_Resume(PRThread *thread)
     PRThreadPriority pri;
-#ifndef _PR_GLOBAL_THREADS_ONLY
     PRIntn is;
-#endif
     PRThread *me = _PR_MD_CURRENT_THREAD();
@@ -1054,5 +1041,3 @@ PR_IMPLEMENT(PRThread*)
_PR_CreateThread
     char *top;
-#ifndef _PR_GLOBAL_THREADS_ONLY
     PRIntn is;
-#endif
     PRIntn native = 0;
@@ -1374,5 +1359,3 @@ PR_IMPLEMENT(PRThread*)
_PRI_AttachThrea
     if (thread) {
-#ifndef _PR_GLOBAL_THREADS_ONLY /* calls to var get thrown
out */
         PRIntn is;
-#endif

@@ -1437,5 +1420,3 @@ PR_IMPLEMENT(void)
PR_DetachThread(void)
 {
-#ifndef _PR_GLOBAL_THREADS_ONLY /* calls to var get thrown
out */
     PRIntn is;
-#endif
     PRThread *me = _PR_MD_CURRENT_THREAD();
@@ -1473,5 +1454,3 @@ PR_IMPLEMENT(PRStatus)
PR_JoinThread(PRT
 {
-#ifndef _PR_GLOBAL_THREADS_ONLY /* calls to var get thrown
out */
     PRIntn is;
-#endif
     PRCondVar *term;
Updated by Wan-Teh Chang (wtc@netscape.com) on Friday, April 24, 1998 12:34:52 PM PDT
Additional Details :
Assigned bug to myself.

Updated

20 years ago
Assignee: nobody → wtc
Status: ASSIGNED → NEW
Component: NSPR
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Comment 2

20 years ago
Wan-Teh, these are some pretty old bugs. i can't help but assume they have
been fixed by now. If you don't have any objections, i will close out and
verify these bugs in a couple of days: 146, 148, 149, 150, 151, 152, 154

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 3

20 years ago
please take corrective action if this is not doing the Right Thing, but,
as it has been a while, i'm marking these fixed and will immediately verify:
bugs 146, 148, 149, 150, 151, 152, 154

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
verified.

Comment 5

20 years ago
NSPR now has its own Bugzilla product.  Moving this bug to the NSPR product.

Updated

4 years ago
Duplicate of this bug: 1098706
You need to log in before you can comment on or make changes to this bug.