Extension options are limited by card size

RESOLVED WONTFIX

Status

()

defect
P1
normal
RESOLVED WONTFIX
6 months ago
2 months ago

People

(Reporter: contact, Assigned: mstriemer)

Tracking

64 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

- installed the wallabagger addon
- click on the addon line to go to preferences


Actual results:

- can't see the second part of the second column


Expected results:

- should see that part

I know that I can fix that with CSS but wanted to know why you reduced the space so drastically.

Updated

6 months ago
Blocks: 1490366
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
(Assignee)

Comment 1

6 months ago
The width changed to match about:preferences since the two pages are now linked to each other.

This could be an issue for many add-ons so I will take a look at possibly leaving the extension's section full width or at least wider.
Assignee: nobody → mstriemer
Priority: -- → P1
(Assignee)

Updated

6 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: about:addon column size → Extension options are limited by card size
(Assignee)

Comment 2

6 months ago
Some add-ons expect their settings to be really wide, and they were
constrained by the cards layout. This moved the settings underneath the card
and adds a heading when they exist. This hasn't been reviewed by UX so this
is still WIP.
Attachment #9021357 - Attachment is obsolete: true
Attachment #9018429 - Attachment is obsolete: true
(Reporter)

Comment 4

3 months ago

Hi there,
Any news about this please?

(Assignee)

Comment 5

2 months ago

Hi, we aren't planning on making any changes here after all. I should have closed this bug before but forgot, sorry.

While implementing a fix and testing the current UI with several add-ons we found that most add-on's UIs worked fine with the new layout.

The issue with the wallabager add-on appears to be that there is a minimum required width which is less than the new layout's width. This was the only add-on we found that didn't work properly in the new layout.

The fix for extensions with a larger minimum width would have caused many add-ons that worked quite well with the new layout to be much wider and appear out of place. This would likely result in those add-ons defining a max-width to fit better with the rest of the UI, and then we'll start running into this again if the width ever changes.

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

2 months ago

Sorry for bothering you again but I disagree. There should be an identical behavior between every browser using webextensions. You have to make this a standard because if not, we will need extra efforts to make this work on each browser.
In this precise case, Firefox has a fixed width where Chromium open a popup without any size. If I want my layout to be more complex than a simple column, I have to manage specific code.
I don't mind which solution is adopted, I just want the behavior to be the same, this is what I expect from a cross browser standard.

(Assignee)

Comment 7

2 months ago

If you add open_in_tab: true to your options_ui section [1] then it will open in a new tab and this constraint won't exist.

The other extensions I looked at either had the overflow property set in their CSS to allow horizontal scrolling of extensions or didn't have a fixed minimum width. You don't need a different UI for both browsers, but rather support for narrower screens.

You can see the same problem in Chrome if you shrink the width of the window (two window split on a laptop, or about the same as their settings page). The same behaviour occurs, the right table is cut off and you can't scroll over to see it or click the X to close the options menu.

[1] https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/options_ui#Syntax

(Reporter)

Comment 8

2 months ago

Thank you for this precise and useful answer. I didn't know about the open_in_tab option. I think I'll do that!
Have a nice day.

You need to log in before you can comment on or make changes to this bug.