Closed Bug 1500015 Opened 4 years ago Closed 4 years ago

Intermittent ProfileBuffer parse error: expected one or more frame entriesAssertion failure: false (expected one or more frame entries), at z:/build/build/src/tools/profiler/core/ProfileBufferEntry.cpp:1102

Categories

(Core :: Gecko Profiler, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1497985

People

(Reporter: ebalazs_, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

+++ This bug was initially created as a clone of Bug #1497985 +++

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=206083058&repo=mozilla-beta&lineNumber=875

https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&resultStatus=testfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&selectedJob=206083058

 TEST-START | GeckoProfiler.Counters
12:27:12     INFO -  ProfileBuffer parse error: expected one or more frame entriesAssertion failure: false (expected one or more frame entries), at z:/build/build/src/tools/profiler/core/ProfileBufferEntry.cpp:1102
12:27:30     INFO -  #01: StreamSamplesAndMarkers(char const *,int,ProfileBuffer const &,SpliceableJSONWriter &,mozilla::TimeStamp const &,mozilla::TimeStamp const &,mozilla::TimeStamp const &,double,UniqueStacks &) [tools/profiler/core/ProfiledThreadData.cpp:160]
12:27:30     INFO -  #02: ProfiledThreadData::StreamJSON(ProfileBuffer const &,JSContext *,SpliceableJSONWriter &,mozilla::TimeStamp const &,double) [tools/profiler/core/ProfiledThreadData.cpp:60]
12:27:30     INFO -  #03: static void locked_profiler_stream_json_for_this_process(const class mozilla::BaseAutoLock<PSMutex &> & const, class SpliceableJSONWriter & const, double, bool) [tools/profiler/core/platform.cpp:1894]
12:27:30     INFO -  #04: profiler_stream_json_for_this_process(SpliceableJSONWriter &,double,bool) [tools/profiler/core/platform.cpp:1957]
12:27:30     INFO -  #05: GeckoProfiler_Counters_Test::TestBody() [tools/profiler/tests/gtest/GeckoProfiler.cpp:569]
12:27:30     INFO -  #06: testing::internal::HandleSehExceptionsInMethodIfSupported<testing::Test,void>(testing::Test *,void ( testing::Test::*)(void),char const *) [testing/gtest/gtest/src/gtest.cc:2406]
12:27:30     INFO -  #07: testing::Test::Run() [testing/gtest/gtest/src/gtest.cc:2476]
12:27:30     INFO -  #08: testing::TestInfo::Run() [testing/gtest/gtest/src/gtest.cc:2662]
12:27:30     INFO -  #09: testing::TestCase::Run() [testing/gtest/gtest/src/gtest.cc:2775]
12:27:30     INFO -  #10: testing::internal::UnitTestImpl::RunAllTests() [testing/gtest/gtest/src/gtest.cc:4649]
12:27:30     INFO -  #11: testing::internal::HandleSehExceptionsInMethodIfSupported<testing::internal::UnitTestImpl,bool>(testing::internal::UnitTestImpl *,bool ( testing::internal::UnitTestImpl::*)(void),char const *) [testing/gtest/gtest/src/gtest.cc:2406]
12:27:30     INFO -  #12: testing::UnitTest::Run() [testing/gtest/gtest/src/gtest.cc:4259]
12:27:30     INFO -  #13: mozilla::RunGTestFunc(int *,char * *) [testing/gtest/mozilla/GTestRunner.cpp:113]
12:27:30     INFO -  #14: XREMain::XRE_mainStartup(bool *) [toolkit/xre/nsAppRunner.cpp:3968]
12:27:30     INFO -  #15: XREMain::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/nsAppRunner.cpp:4907]
12:27:30     INFO -  #16: XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/nsAppRunner.cpp:5014]
12:27:30     INFO -  #17: mozilla::BootstrapImpl::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/Bootstrap.cpp:49]
12:27:30     INFO -  #18: NS_internal_main(int,char * *,char * *) [browser/app/nsBrowserApp.cpp:315]
12:27:30     INFO -  #19: wmain [toolkit/xre/nsWindowsWMain.cpp:143]
12:27:30     INFO -  #20: static int __scrt_common_main_seh() [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:288]
12:27:30     INFO -  #21: kernel32.dll + 0x53c45
12:27:30     INFO -  #22: ntdll.dll + 0x637f5
12:27:30     INFO -  #23: ntdll.dll + 0x637c8
12:27:30     INFO -  mozcrash INFO | Copy/paste: Z:\task_1539777400\build\win32-minidump_stackwalk.exe Z:\task_1539777400\build\tests\gtest\7ac19689-0f98-4788-bb6d-92eaf292fd2a.dmp Z:\task_1539777400\build\symbols
12:27:43     INFO -  mozcrash INFO | Saved minidump as Z:\task_1539777400\build\blobber_upload_dir\7ac19689-0f98-4788-bb6d-92eaf292fd2a.dmp
12:27:43     INFO -  mozcrash INFO | Saved app info as Z:\task_1539777400\build\blobber_upload_dir\7ac19689-0f98-4788-bb6d-92eaf292fd2a.extra
12:27:43  WARNING -  PROCESS-CRASH | gtest | application crashed [@ ProfileBuffer::StreamSamplesToJSON(SpliceableJSONWriter &,int,double,UniqueStacks &)]
12:27:43     INFO -  Crash dump filename: Z:\task_1539777400\build\tests\gtest\7ac19689-0f98-4788-bb6d-92eaf292fd2a.dmp
12:27:43     INFO -  Operating system: Windows NT
12:27:43     INFO -                    6.1.7601 Service Pack 1
12:27:43     INFO -  CPU: x86
12:27:43     INFO -       GenuineIntel family 6 model 63 stepping 2
12:27:43     INFO -       8 CPUs
12:27:43     INFO -  GPU: UNKNOWN
12:27:43     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
12:27:43     INFO -  Crash address: 0x58c55af6
12:27:43     INFO -  Process uptime: 354 seconds
12:27:43     INFO -  Thread 0 (crashed)
12:27:43     INFO -   0  xul.dll!ProfileBuffer::StreamSamplesToJSON(SpliceableJSONWriter &,int,double,UniqueStacks &) [ProfileBufferEntry.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 1102 + 0x0]
12:27:43     INFO -      eip = 0x58c55af6   esp = 0x003aed90   ebp = 0x003aeea4   ebx = 0x00000253
12:27:43     INFO -      esi = 0x0b0e0e20   edi = 0x00000000   eax = 0x00000000   ecx = 0x00000000
12:27:43     INFO -      edx = 0x00000000   efl = 0x00000216
12:27:43     INFO -      Found by: given as instruction pointer in context
12:27:43     INFO -   1  xul.dll!StreamSamplesAndMarkers(char const *,int,ProfileBuffer const &,SpliceableJSONWriter &,mozilla::TimeStamp const &,mozilla::TimeStamp const &,mozilla::TimeStamp const &,double,UniqueStacks &) [ProfiledThreadData.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 157 + 0x2c]
12:27:43     INFO -      eip = 0x58c58a4b   esp = 0x003aeeac   ebp = 0x003aef48
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   2  xul.dll!ProfiledThreadData::StreamJSON(ProfileBuffer const &,JSContext *,SpliceableJSONWriter &,mozilla::TimeStamp const &,double) [ProfiledThreadData.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 60 + 0x3a]
12:27:43     INFO -      eip = 0x58c584bf   esp = 0x003aef50   ebp = 0x003af0a8
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   3  xul.dll!static void locked_profiler_stream_json_for_this_process(const class mozilla::BaseAutoLock<PSMutex &> & const, class SpliceableJSONWriter & const, double, bool) [platform.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 1899 + 0x2e]
12:27:43     INFO -      eip = 0x58c5bf32   esp = 0x003af0b0   ebp = 0x003af258
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   4  xul.dll!profiler_stream_json_for_this_process(SpliceableJSONWriter &,double,bool) [platform.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 1957 + 0x15]
12:27:43     INFO -      eip = 0x58c5aef9   esp = 0x003af260   ebp = 0x003af278
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   5  xul.dll!GeckoProfiler_Counters_Test::TestBody() [GeckoProfiler.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 569 + 0xc]
12:27:43     INFO -      eip = 0x598933d8   esp = 0x003af280   ebp = 0x003af328
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   6  xul.dll!testing::internal::HandleSehExceptionsInMethodIfSupported<testing::Test,void>(testing::Test *,void ( testing::Test::*)(void),char const *) [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 2389 + 0xa]
12:27:43     INFO -      eip = 0x595271d1   esp = 0x003af330   ebp = 0x003af370
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   7  xul.dll!testing::Test::Run() [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 2476 + 0x29]
12:27:43     INFO -      eip = 0x59507b36   esp = 0x003af378   ebp = 0x003af398
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   8  xul.dll!testing::TestInfo::Run() [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 2658 + 0x7]
12:27:43     INFO -      eip = 0x59508e0c   esp = 0x003af3a0   ebp = 0x003af3e0
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -   9  xul.dll!testing::TestCase::Run() [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 2776 + 0x5]
12:27:43     INFO -      eip = 0x59509448   esp = 0x003af3e8   ebp = 0x003af420
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  10  xul.dll!testing::internal::UnitTestImpl::RunAllTests() [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 4651 + 0x5]
12:27:43     INFO -      eip = 0x59511358   esp = 0x003af428   ebp = 0x003af474
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  11  xul.dll!testing::internal::HandleSehExceptionsInMethodIfSupported<testing::internal::UnitTestImpl,bool>(testing::internal::UnitTestImpl *,bool ( testing::internal::UnitTestImpl::*)(void),char const *) [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 2389 + 0xa]
12:27:43     INFO -      eip = 0x59527ad1   esp = 0x003af47c   ebp = 0x003af4bc
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  12  xul.dll!testing::UnitTest::Run() [gtest.cc:5f2b0964547892553bc6af517074c87c19bd019d : 4259 + 0x2c]
12:27:43     INFO -      eip = 0x59510fe5   esp = 0x003af4c4   ebp = 0x003af4ec
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  13  xul.dll!mozilla::RunGTestFunc(int *,char * *) [GTestRunner.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 113 + 0xc]
12:27:43     INFO -      eip = 0x59528bf9   esp = 0x003af4f4   ebp = 0x003af538
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  14  xul.dll!XREMain::XRE_mainStartup(bool *) [nsAppRunner.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 3968 + 0xd]
12:27:43     INFO -      eip = 0x58f85f37   esp = 0x003af540   ebp = 0x003af69c
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  15  xul.dll!XREMain::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [nsAppRunner.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 4907 + 0x9]
12:27:43     INFO -      eip = 0x58f8c6ab   esp = 0x003af6a4   ebp = 0x003af6fc
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  16  xul.dll!XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [nsAppRunner.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 5014 + 0xc]
12:27:43     INFO -      eip = 0x58f8d291   esp = 0x003af704   ebp = 0x003af830
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  17  xul.dll!mozilla::BootstrapImpl::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [Bootstrap.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 49 + 0xe]
12:27:43     INFO -      eip = 0x58f9e321   esp = 0x003af838   ebp = 0x003af844
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  18  firefox.exe!NS_internal_main(int,char * *,char * *) [nsBrowserApp.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 315 + 0x32]
12:27:43     INFO -      eip = 0x001b1477   esp = 0x003af84c   ebp = 0x003af9a8
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  19  firefox.exe!wmain [nsWindowsWMain.cpp:5f2b0964547892553bc6af517074c87c19bd019d : 143 + 0x11]
12:27:43     INFO -      eip = 0x001b11cd   esp = 0x003af9b0   ebp = 0x003af9d4
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  20  firefox.exe!static int __scrt_common_main_seh() [exe_common.inl : 288 + 0x1c]
12:27:43     INFO -      eip = 0x0020da18   esp = 0x003af9dc   ebp = 0x003afa1c
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  21  kernel32.dll!BaseThreadInitThunk + 0x12
12:27:43     INFO -      eip = 0x75f43c45   esp = 0x003afa24   ebp = 0x003afa28
12:27:43     INFO -      Found by: previous frame's frame pointer
12:27:43     INFO -  22  ntdll.dll!CreatePipe + 0x231
12:27:43     INFO -      eip = 0x779d37f5   esp = 0x003afa30   ebp = 0x003afa68
12:27:43     INFO -      Found by: call frame info
12:27:43     INFO -  23  ntdll.dll!CreatePipe + 0x204
12:27:43     INFO -      eip = 0x779d37c8   esp = 0x003afa70   ebp = 0x003afa80
12:27:43     INFO -      Found by: call frame info
This seems to be in beta, I believe this happened when we didn't merge the fix from bug 1497985 yet (which should happen automatically while we're in the RC period).
I'll dupe to bug 1497985 for now but please reopen if this happens again in beta or central in the future.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.