Closed Bug 1500117 Opened 1 year ago Closed 1 year ago

WebDriver:TakeScreenshot returns empty string on http://creppy.hu/

Categories

(Testing :: Marionette, defect)

62 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1471262

People

(Reporter: suletom, Unassigned)

Details

Attachments

(1 file)

Attached file sc_bugtest.php.zip
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

Tried on OS: ubuntu 16.04/18.04
Firefox: 62.0.3 (64 bit) (from official repo)

1. open command line, run firefox: #firefox --marionette
2. Run the attached script on other terminal:

#php sc_bugtest.php localhost 2828 http://creppy.hu

Taking automated screenshot fails, no reason appears in console/browser console.
Manually taking a screenshot from the right click menu on http://creppy.hu works as expected. I suspect the problem is also reproducable with selenium or any other automation tool.

Working case:

#php sc_bugtest.php localhost 2828 http://hackaday.com
Output on last line: Test PASSED!

Bug:

#php sc_bugtest.php localhost 2828 http://creppy.hu
Output on last line: Error in response, no screenshot: [1,3,null,{"value":""}]



Actual results:

Output on last line: Error in response, no screenshot: [1,3,null,{"value":""}]
Full log output:

ip:localhost
port:2828
url:http://creppy.hu
fsockopen(localhost,2828).....
Conn Ok!

reader:50:{"applicationType":"gecko","marionetteProtocol":3}
writer:101:[0,0,"WebDriver:NewSession",{"acceptInsecureCerts":true,"capabilities":{"acceptInsecureCerts":true}}]

writer:49:[0,1,"Marionette:SetContext",{"value":"content"}]

reader:25:[1,1,null,{"value":null}]
writer:55:[0,2,"WebDriver:Navigate",{"url":"http:\/\/creppy.hu"}]

reader:25:[1,2,null,{"value":null}]
writer:46:[0,3,"WebDriver:TakeScreenshot",{"full":true}]

SCHREENSHOT response got!
Error in response, no screenshot: [1,3,null,{"value":""}]



Expected results:

Output on last line: Test PASSED!
Full log output:

ip:localhost
port:2828
url:http://hackaday.com
fsockopen(localhost,2828).....
Conn Ok!

reader:50:{"applicationType":"gecko","marionetteProtocol":3}
writer:101:[0,0,"WebDriver:NewSession",{"acceptInsecureCerts":true,"capabilities":{"acceptInsecureCerts":true}}]

writer:49:[0,1,"Marionette:SetContext",{"value":"content"}]

reader:25:[1,1,null,{"value":null}]
writer:58:[0,2,"WebDriver:Navigate",{"url":"http:\/\/hackaday.com"}]

reader:25:[1,2,null,{"value":null}]
writer:46:[0,3,"WebDriver:TakeScreenshot",{"full":true}]

SCHREENSHOT response got!
Image string not empty!
Test PASSED!
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Summary: Taking automated screenshot with marionette not working on a site → WebDriver:TakeScreenshot returns empty string on
Duplicate of bug: 1471262
Summary: WebDriver:TakeScreenshot returns empty string on → WebDriver:TakeScreenshot returns empty string on http://creppy.hu/
Component: Untriaged → Marionette
Product: Firefox → Testing
The bug can be reproduced with the following code on a local html file:

<!DOCTYPE html>
<html>
    <head>
        <style>
            body {
                margin: 0
            }
        </style>
    </head>
    <body></body>
</html>
Let’s continue the conversation over at https://bugzilla.mozilla.org/show_bug.cgi?id=1471262.
You need to log in before you can comment on or make changes to this bug.