Closed Bug 150018 Opened 22 years ago Closed 22 years ago

Mozilla/Installer requirement not listed: ContextualMenu Library

Categories

(SeaMonkey :: Build Config, defect)

PowerPC
Mac System 9.x
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: scully, Assigned: timeless)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052917

When installing, the installer will quit with an error message "ContextualMenu
Library Not Found" if the Contextual Menus Extension has been turned off.  While
the install notes mention "Do not install with Extensions off", I think it
should explicitly list this dependency, or at least refuse to install without
the library present.  Instead it got me most of the way through the process and
the errored out.  

This is obviously a minor minor issue.  Thanks for the good work, I really enjoy
the program.

Reproducible: Didn't try
Steps to Reproduce:
1.  Turn off "Contextual Menu Extension" in Extension Manager.
2.  Restart.
3.  Run Net Installer.

Actual Results:  It errors out of the install, with a message "ContextualMenu
Library Not Found".

Expected Results:  It should have warned me before running the installation
process.  It also probably should have done nothing, since I don't see how
Contextual Menus are used in the installer.
QA Contact: bugzilla → ktrina
Afaik Mozilla requires it because NSStdLib.shlb referenecs it.
And afaik that's not in the release notes either.

file:///I:/tempoverflow/mac/ppc_cvs/mozilla/lib/mac/NSStdLib/src/macstdlibextras.c

1.12 <sfraser@netscape.com> 01 May 2000 17:37
Extra check to make sure contextual menu manager is installed before initting it.

Apps tested: Full Installer, Mozilla [installed]. Not tested: Net instsller (I
trust you and have no patience for it)

smfr: if you don't want to work on this, send it my way and i'll look for a hero.
Assignee: dveditz → sfraser
Status: UNCONFIRMED → NEW
Component: Installer → Build Config
Ever confirmed: true
QA Contact: ktrina → timeless
Summary: Installer requirement not listed → Mozilla/Installer requirement not listed: ContextualMenu Library
You asked for it!
Assignee: sfraser → timeless
relnoted 1.0, 1.1 and future
now the hard part...
Assignee: timeless → timeless
Quoth Steve Dagley: "The Mac installer code was never Carbonized and there is no
intention to ever change that."

http://groups.google.com/groups?threadm=yahoo_com-77F6E8.09344011022003%40h-204-29-187-156.netscape.com
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.