Closed Bug 1500236 Opened Last year Closed Last year

Have Raptor use '127.0.0.1' instead of 'localhost' to fix timeouts on OSX

Categories

(Testing :: Raptor, enhancement)

Version 3
enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: rwood, Assigned: rwood)

References

Details

Attachments

(1 file)

Andrew noted that Raptor (speedometer) is quite often timing out on OSX when running locally - instead of the benchmark loading, Firefox reports it cannot access the localhost. I have also seen this on my MacBook.

We changed raptor locally to use '127.0.0.1' instead of 'localhost' and it appears to fix it.

This is the same issue as reported in Talos in Bug 1499739 - looks like there are issues on OSX resolving 'locahost' very slowly vs using the IP.
From :jmaher in phab:

can we change this to be:
http://<host:port>/

then we can replace <host:port> with something dynamic (this leaves room for quicker changes to static and/or remote web servers)
Ok so adding the <port> part will be done in Bug 1499352
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b5eee61ba434
Have Raptor use '127.0.0.1' instead of 'localhost' to fix timeouts on OSX; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/b5eee61ba434
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.